NYOJ - 715 - Adjacent Bit Counts --第六届河南省程序设计大赛 (DP!!)

Adjacent Bit Counts

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

For a string of n bits x1, x2, x3, …, xn,  the adjacent bit count of the string  is given by     fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:  

     Fun(011101101) = 3

     Fun(111101101) = 4

     Fun (010101010) = 0

Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy  Fun(x) = p.

 

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case is a single line that contains a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100
输出
For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.
样例输入
2
5 2
20 8 
样例输出
663426
来源
第六届河南省程序设计大赛


简单DP题。。

定义数组dp[105][105][2];其中dp[i][j][0]代表第j位是0的时候长度为j的串组成值为i的串的种数,dp[i][j][1]代表

j位是1的时候长度为j的串组成值为i的串的种数,

容易看出dp[i][j][0]=dp[i][j-1][0]+dp[i][j-1][1];   dp[i][j][1]=dp[i-1][j-1][1]+dp[i][j-1][0];

所以,初始化先把f的值全部赋成0.然后dp[0][1][0]=dp[0][1][1]=1;然后再求出所有dp[0][j][0]和dp[0][j][1]的值;

之后两个for循环就ok了!



AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

long long dp[105][105][2];

void init()
{
	memset(dp, 0, sizeof(dp));
	dp[0][1][0] = 1;
	dp[0][1][1] = 1;
	for(int i=2; i<=100; i++)
	{
		dp[0][i][0] = dp[0][i-1][0] + dp[0][i-1][1];
		dp[0][i][1] = dp[0][i-1][0];
	}
	for(int i=1; i<=100; i++)
		for(int j=2; j<=100; j++)
		{
			dp[i][j][0] = dp[i][j-1][1] + dp[i][j-1][0];
			dp[i][j][1] = dp[i-1][j-1][1] + dp[i][j-1][0];
		}
}
 
int main()
{
	init();
	int k, n, p;
	scanf("%d", &k);
	while(k--)
	{
		scanf("%d %d", &n, &p);
		printf("%I64d\n", dp[p][n][0]+dp[p][n][1]);	
	}
	return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值