SGU - 302 - BHTML 1.0 (栈的应用)

302. BHTML 1.0
Time limit per test: 0.25 second(s)
Memory limit: 65536 kilobytes
input: standard
output: standard



The hypertext markup language BHTML 1.0 has only two paired tags. They are  UP   /UP  and  DOWN   /DOWN . The  UP   /UP  tag capitalizes all letters inside its body (between an open tag and a close one), and  DOWN   /DOWN  makes all inside the body letters lowercase. You are given the text consisting of latin letters and tags. Your task is to write the text right as it will be shown in the Bernet Explorer browser window. Tags in the text are arranged correctly, i.e. they form correct bracket sequence. If a letter lays inside several tags, its case is defined by the most inner tag.

Input
The input contains the string  S with the text. The length of the string is a natural number not exceeding 1000. Tags are always written in uppercase.

Output
Write to the output text after the processing.

Example(s)
sample input
sample output
Thi<UP>sIs<DOWN>EaSY</DOWN>Pr<UP>O</UP>ble</UP>m 
ThiSISeasyPROBLEm 




Online Contester Team © 2002 - 2010. All rights reserved.





思路:栈的应用,具体看代码;


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;

char str[1005];

int main() {
	while(gets(str) != NULL) {
		stack<int> s;
		int len = strlen(str);
		for(int i = 0; i < len; i++) {
			if(str[i] == '<') {
				if(str[i+1] == 'U') { s.push(1); i += 3; }
				else if(str[i+1] == 'D') { s.push(2); i += 5; }
				else if(str[i+1] == '/') {
					s.pop();
					if(str[i+2] == 'U') i += 4;
					else if(str[i+2] == 'D') i += 6;
				}
			}
			else if(s.empty()) {
				printf("%c", str[i]);
			}
			else if(s.top() == 1) {
				if(str[i] >= 'a' && str[i] <= 'z') printf("%c", str[i]-32);
				else printf("%c", str[i]);
			}
			else if(s.top() == 2) {
				if(str[i] >= 'A' && str[i] <= 'Z') printf("%c", str[i]+32);
				else printf("%c", str[i]);
			}
		}
		printf("\n");
	}
	return 0;
}











  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值