HDU 1829 A Bug's Life

 

Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

 

Input

 

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

 

Output

 

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

 

Sample Input

 

 
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

 

Sample Output

 

 
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.

 

 

 

本题的意思是有一些虫子,他们都是喜欢异性的,不存在任何一只虫子有两种性别,判断是否存在双性恋的虫子。

例如样例1

1 2 说明1和2不同性别

2 3 说明2和3不同性别

由此2组得知1和3同性,2另外一个性别

1 3 说明1和3不同性别,矛盾

所以NO

以下给出三组NO的较为特殊数据

4 4        5 5         6 5

1 2        1 2         1 2

2 3        4 5         3 4

3 4        2 3         4 5

1 4        3 4         2 3

              2 5         5 6

 

 

以下为代码

 

#include<stdio.h>
int root[2005];
int dis[2005];
bool tag;
int n,m;
void init(int n)
{
	for(int i=1;i<=n;i++)
	{
		dis[i]=0;
		root[i]=i;
	}
	tag=true;
}
int find(int x)
{
	if(root[x]!=x)
	{
		int ps;//根在下一步会被压缩
		ps=root[x];
		root[x]=find(root[x]);
		dis[x]=(dis[x]+dis[ps])%2;//为了方便判断两点间是否不同性,可通过奇偶性判断
	}
	return root[x];
}
void un(int x,int y)
{
	int a,b;
	a=find(x);
	b=find(y);
	if(a!=b)
	{
		root[a]=b;
		dis[a]=(1+dis[x]-dis[y])%2;//改变a的根的同时,需改变a到根的距离
	}
	find(x);//随着a的根改变,x距离根的距离也需改变
}
int main()
{
	int t,co=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		init(n);
		while(m--)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			if(tag)//若已出现不同性的剩下数据只需输入即可
				un(x,y);
			if(dis[x]==dis[y])
				tag=false;
		}
		printf("Scenario #%d:\n",++co);
		if(tag)
			printf("No suspicious bugs found!\n\n");
		else
			printf("Suspicious bugs found!\n\n");
	}
	return 0;
}

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值