HDU 1147 Pick-up sticks(线段是否相交)

Pick-up sticks

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2034    Accepted Submission(s): 764


Problem Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
 

Input
Input consists of a number of cases. The data for each case start with 1 ≤ n ≤ 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed. 
 

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 
The picture to the right below illustrates the first case from input.
 

Sample Input
  
  
5 1 1 4 2 2 3 3 1 1 -2.0 8 4 1 4 8 2 3 3 6 -2.0 3 0 0 1 1 1 0 2 1 2 0 3 1 0
 

Sample Output
  
  
Top sticks: 2, 4, 5. Top sticks: 1, 2, 3.
给你n个棍子,棍子按顺序依次放下,每行四个数是棍子的两端坐标,问放下所有棍子后,有多少棍子没有被别的棍子压住(即有交点)
所以题目是求与其他棍子 没有交点 的棍子
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
struct node
{
    double  x1,y1,x2,y2;
}a[120002];

int yice(node a,node b)
{
    double  s1,s2;
    s1=b.x1*(a.y2-a.y1) + a.x2*a.y1-a.x1*a.y2 - b.y1*(a.x2-a.x1);
    s2=b.x2*(a.y2-a.y1) + a.x2*a.y1-a.x1*a.y2 - b.y2*(a.x2-a.x1);
    if(s1*s2<=0)
        return 1;
    else return 0;
}
int main()
{
    int n,i,j;
    while(scanf("%d",&n),n)
   {
       for(i=1;i<=n;i++)
       scanf("%lf%lf%lf%lf",&a[i].x1,&a[i].y1,&a[i].x2,&a[i].y2);
       int ss[120001];
       int k=0;
       for(i=1;i<=n;i++)
           {
               int f=1;
          for(j=i+1;j<=n;j++)
              {
                if(i!=j && yice(a[i],a[j]) && yice(a[j],a[i]))
                 {
                     f=0;
                     break;
                 }
              }
              if(f)
               ss[k++]=i;

           }
           printf("Top sticks: ");
        for(i=0;i<k-1;i++)
              printf("%d, ",ss[i]);
              printf("%d.\n",n);
    }
    return 0;
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值