HDU 5366 The mook jong(递推)

The mook jong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 365    Accepted Submission(s): 283


Problem Description
![](../../data/images/C613-1001-1.jpg)

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).
 

Input
There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)
 

Output
Print the ways in a single line for each case.
 

Sample Input
  
  
1 2 3 4 5 6
 

Sample Output
  
  
1 2 3 5 8 12
1*n的格子 ,每个格子可以放一个木人桩,相邻的木人桩最少隔 两个格子 ,求至少放一个木人桩的不同放法数
f[i] = f[i-1] + f[i-3] + 1
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <cmath>
#include <map>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
    
    __int64 b[65];
        b[1]=1;
        b[2]=2;
        b[3]=3;
        for(int i=4;i<=60;i++)
        {
            b[i]=b[i-1]+b[i-3]+1;
        }
        int n;
    while(~scanf("%d",&n))
    {
        printf("%I64d\n",b[n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值