HDU 3549 Flow Problem

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 7865    Accepted Submission(s): 3659


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
      
      
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
      
      
Case 1: 1 Case 2: 2
题意很简单 ,就是一个简单的最大流问题,模板直接过。。。作为一个新手刚学 表示理解的还是不怎么深刻,跟龙哥调了一上午也没发现错在哪。。啥都不说了,都是泪啊 上代码
#include <iostream>
#include <queue>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define N 25
#define MAX 9999999
using namespace std;
int n,m;
int vis[N];
int map1[N][N],pre[N];

int bfs(int s,int e)
{
    memset(vis, 0, sizeof(vis));
    memset(pre,-1,sizeof(pre));
    pre[s]=0;
    vis[s]=MAX;
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int k = q.front();
        q.pop();
        if(k==e) break;
        for(int i=1; i<=n; i++)
        {
            if(map1[k][i]>0 && pre[i]==-1)
            {
                pre[i] = k;
                vis[i] = min(map1[k][i],vis[k]);       //一开始while外了,也没错就是交不上,后来放着居然就A了
                q.push(i);
            }
        }
    }
    if(pre[e]==-1)
        return -1;
    return vis[e];
}
int zuida(int s,int e)
{
    int ans=0;
    while(1)
    {
        int y = bfs(s,e);
        if(y == -1)  break;
        for(int i = n; i != 1; i = pre[i])
        {
            map1[pre[i]][i] -= y;
            map1[i][pre[i]] += y;
        }
        ans+=y;
    }
    return ans;
}

int main()
{
    int T;
    int Case = 1;
    scanf("%d",&T);
    while(T--)
    {
        memset(map1,0,sizeof(map1));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            map1[a][b]+= c;
        }
        int ans=zuida(1, n);
        cout<<"Case "<<Case++<<": ";
        printf("%d\n",ans);
    }

    return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值