POJ 3126 Prime Path (BFS)

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11589 Accepted: 6579

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
一道简单的搜索题,只要搞清题意便不难理解。。
给你两个四位的正整数,并都为素数,每次可以变 个十百千位 中的一个数(变化后也是素数),问最少多少次两个数相等,如果不能输出Impossible,,,交的时候交的c++ CE,G++过了(死在了sqrt上)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <math.h>
using namespace std;
struct node
{
    int s1,s2,s3,s4;
    int sum;
} q[1000000];
int n,m;
int b[10001];
int sushu(int x)
{
   int t=sqrt(x);
    for(int i=2;i<=t;i++)
    {
        if(x%i==0)
         return 0;
    }
    return 1;
}
void bfs()
{
    memset(b,0,sizeof(b));
    struct node t,r;
    t.s1=n%10;
    n=n/10;
    t.s2=n%10;
    n=n/10;
    t.s3=n%10;
    n=n/10;
    t.s4=n%10;
    t.sum=0;
    int k=0,l=0;
    q[l++]=t;
    while(k<l)
    {
        t=q[k++];
        if(t.s4*1000 + t.s3*100 + t.s2*10 + t.s1 == m)
        {
            cout<<t.sum<<endl;
            return ;
        }
        for(int i=1; i<=9; i++)    //千位不能从0开始,找了好久才发现这个错,还是思考不够严谨啊
        {
            if(i!=t.s4)
            {
                int x=i*1000 + t.s3*100 + t.s2*10 + t.s1;
                if(sushu(x) && !b[x])
                {
                    r.s4=i;
                    r.s3=t.s3;
                    r.s2=t.s2;
                    r.s1=t.s1;
                    r.sum=t.sum+1;
                    q[l++]=r;
                    b[x]=1;
                }
            }
        }
          for(int i=0; i<=9; i++)
        {
            if(i!=t.s3)
            {
                int x=t.s4*1000 + i*100 +t.s2*10 + t.s1;
                if(sushu(x) && !b[x])
                {
                    r.s4=t.s4;
                    r.s3=i;
                    r.s2=t.s2;
                    r.s1=t.s1;
                    r.sum=t.sum+1;
                    q[l++]=r;
                    b[x]=1;

                }
            }
        }
         for(int i=0; i<=9; i++)
        {
            if(i!=t.s2)
            {
                int x=t.s4*1000 + t.s3*100 +i*10 + t.s1;
                if(sushu(x) && !b[x])
                {
                    r.s4=t.s4;
                    r.s3=t.s3;
                    r.s2=i;
                    r.s1=t.s1;
                    r.sum=t.sum+1;
                    q[l++]=r;
                    b[x]=1;

                }
            }
        }
         for(int i=0; i<=9; i++)
        {
            if(i!=t.s1)
            {
                int x=t.s4*1000 + t.s3*100 +t.s2*10 + i;
                if(sushu(x) && !b[x])
                {
                    r.s4=t.s4;
                    r.s3=t.s3;
                    r.s2=t.s2;
                    r.s1=i;
                    r.sum=t.sum+1;
                    q[l++]=r;
                    b[x]=1;

                }
            }
        }

   }
    cout<<"Impossible"<<endl;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        bfs();
    }

    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值