Artificial Intelligence?(字符串处理)

Artificial Intelligence?
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


  Artificial Intelligence? 

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xAU=xV or P=xW, where x is a real number.

Directly before the unit (AV or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and UP and I, or U and I will be given.

Output 

For each test case, print three lines:

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

Sample Input 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V


这道题是给你一句话,其中会包含P,U,I中的两个,让你根据公式求出P=U*I 求出第三个的值并输出。。。

在处理的时候要注意它们的单位,MW(1000000W),kV(1000V),mA(0.001A),然后还要注意这三个的值可能为实数。。

本来我是直接输入每一句话,找到=后判断前后的字符,发现这样不好表示,尤其是在=后面为实数的时候,其实输入的数据也就=前后有用,所以我直接用double保存=后的实数,这样可以直接得到两个实数

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1500;

int main()
{
    int T;
    cin>>T;
    for(int r=1; r<=T; r++)
    {
        char a[N];
        int sa=0;
        while(cin>>a[sa])
        {
            if(a[sa]=='=')
                break;
            sa++;
        }
        double x;
        char tx;
        cin>>x;
        cin>>tx;
        int fp=1,fu=1,fi=1;
        if(tx=='M')
            x*=1000000;
        if(tx=='m')
            x*=0.001;
        if(tx=='k')
            x*=1000;
        if(a[sa-1]=='P')
            fp=0;
        else if(a[sa-1]=='U')
            fu=0;
        else if(a[sa-1]=='I')
            fi=0;


        char b[N];
        int sb=0;
        while(cin>>b[sb])
        {
            if(b[sb]=='=')
                break;
            sb++;
        }
        double y;
        char ty;
        cin>>y;
        cin>>ty;
        int rp=1,ru=1,ri=1;
        if(ty=='M')
            y*=1000000;
        else if(ty=='m')
            y*=0.001;
        else if(ty=='k')
            y*=1000;
        if(b[sb-1]=='P')
            rp=0;
        else if(b[sb-1]=='U')
            ru=0;
        else if(b[sb-1]=='I')
            ri=0;
        printf("Problem #%d\n",r);
        if(!fp && !ri)
            printf("U=%.2lfV\n",x/y);
        if(!fp && !ru)
            printf("I=%.2lfA\n",x/y);

        if(!fu && !rp)
            printf("I=%.2lfA\n",y/x);
        if(!fu && !ri)
            printf("P=%.2lfW\n",x*y);

        if(!fi && !rp)
            printf("U=%.2lfV\n",y/x);
        if(!fi && !ru)
            printf("P=%.2lfW\n",x*y);
        printf("\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值