UVA 10341Solve It(二分求方程解)

16 篇文章 0 订阅

Problem F

Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-xq*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r<= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554
 
给出p,q,r,s,t,u的值,求出方程的近似解
因为方程是递减的,对于两个端点,如果f(0)*f(1)>0 ,则说明方程无解
取两个端点的中点mid 如果f(0)*f(mid)<0  ,说明方程的解在[0,mid]中,否则解在[mid,1]中
这样不断进行下去,区间会收敛于一点,即为最后的近似解
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <cmath>
#define  eps 1e-8
#define N 1000010
using namespace std;
double p,q,r,s,t,u;
double ans(double x)
{
    return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
}
int main()
{
    while(~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u))
    {
        if(ans(0)*ans(1)>0)
        {
             printf("No solution\n");
             continue;
        }
        double left=0;
        double right=1;
         double mid;
        while(right-left>=eps)
        {
             mid=(left+right)/2;
            double y=ans(mid);
            if(y<0)
                right=mid;
            else left=mid;
        }
     printf("%.4lf\n",mid);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值