POJ 2442 Sequence(优先队列)

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8265 Accepted: 2703

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4
 
n*m的一个矩阵,每行取一个数 进行求和 ,输出前m小的和
每行取前m小的存在递增队列中,判断下一行时把所有情况枚举出来,存在递减队列中(m个元素),每次找到比top小的,更新它
#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
#include <map>
#define inf 0x3f3f3f3f
#define N 2001
using namespace std;
int a[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        priority_queue<int ,vector<int >,greater<int> >q;
        priority_queue<int ,vector<int >,less<int > > s;
        for(int i=0; i<m; i++)
        {
            int x;
            scanf("%d",&x);
            q.push(x);
        }
        for(int i=1; i<n; i++)
        {
            for(int j=0; j<m; j++)
                scanf("%d",&a[j]);
            while(!q.empty())
            {
                int sum = q.top();
                q.pop();
                for(int j=0; j<m; j++)
                {
                    int t=s.size();
                    if(t == m && s.top() > sum+a[j])
                    {
                        s.pop();
                        s.push(sum+a[j]);
                    }
                    else if(t<m)
                        s.push(sum+a[j]);
                }
            }
            while(!s.empty())
            {
                q.push(s.top());
                s.pop();
            }

        }
        bool flag = true;
        while(!q.empty())
        {
            if(!flag)
                printf(" %d",q.top());
            else
            {
                printf("%d",q.top());
                flag=false;
            }
            q.pop();
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值