Sequence(贪心+优先队列)

Sequence

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It’s clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

从m个长度为n的序列中各取一个数计算总和,可以组合出n^m个结果,按从小到大的顺序输出前n个结果。数据量比较大,为了避免MLE,只开两个数组一个用于存下一步输入的序列,另一个存已输入的序列所组合出的前n个结果。

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>

using namespace std;

priority_queue<int>q;
int now[2100],next[2100];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&m,&n);
        for(int i=0;i<n;i++)
            scanf("%d",&now[i]);
        for(int i=1;i<m;i++)
        {
            sort(now,now+n);
            for(int j=0;j<n;j++)
                scanf("%d",&next[j]);
            for(int j=0;j<n;j++)
                q.push(now[j]+next[0]);
            for(int j=1;j<n;j++)
            {
                for(int k=0;k<n;k++)
                {
                    int t=now[k]+next[j];
                    if(t>=q.top())//如果t大于队首元素,那么后面的数一定也大于队首,直接结束循环
                        break;
                    q.push(t);
                    q.pop();
                }
            }
            for(int j=n-1;j>=0;j--)
            {
                now[j]=q.top();
                q.pop();
            }
        }
        sort(now,now+n);
        for(int i=0;i<n-1;i++)
            printf("%d ",now[i]);
        printf("%d\n",now[n-1]);
        while(!q.empty())
            q.pop();
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值