POJ 3292 Semi-prime H-numbers(筛选)

16 篇文章 0 订阅
Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8018 Accepted: 3446

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62
 H-numbers 定义为  4*n+1 
H-primes 为 4*n+1 中的素数
H-semi-primes 为两个H-primes的乘积
输出小于h的H-semi-primes个数 
筛选出所有的H-semi-primes即可
 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <stdlib.h>
#include <queue>
#include <algorithm>
#include <vector>
#define inf 0x3f3f3f3f
#define N 1000001
using namespace std;
int h[N];
int a[N];
void sai()
{
    memset(h,0,sizeof(h));
    for(int i=5; i<N; i+=4)
    {
        for(int j=5;j<N;j+=4)
        {
            if(i*j>N) break;
            if(h[i]==0 && h[j]==0)
                h[i*j]=1;
            else h[i*j]=-1;
        }
    }
    int sum=0;
    for(int i=2;i<N;i++)
     {
         if(h[i]==1)
            sum++;
         a[i]=sum;
     }
}
int main()
{

    int n;
    sai();
    while(scanf("%d",&n),n)
    {
        printf("%d %d\n",n,a[n]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值