POJ 3292(筛法)

Semi-prime H-numbers

题目描述

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,… are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it’s the product of three H-primes.

输入

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

输出

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

样例输入
21
85
789
0

样例输出
21 0
85 5
789 62

题目大意:
H-number(x%4==1)分为3种数:
1.H-prime:除了1和他本身没有其他H-number作为他的因子(如5,9,13)
2. H-semi-prime:由两个H-prime相乘得到(如25=5**5,45=5*9)
3. 其他数
输入n,求出0到n有几个 H-semi-prime;

思路
首先两个H-number相乘仍是H-number,并且两个H-prime相乘得到的H-semi-prime不为H-prime,然后我们只考虑可以分解成两个H-prime的H-number,三个及以上的就不考虑了;

那么我们可以用筛法的思想:
用数组a[i],若i可以表示成两个H-prime相乘的话,则将i标记为1(a[i]=1),否则标记为-1(a[i]=-1),标记为-1的意义i即不为 H-semi-prime也不为H-prime,i为第三类数;要记得标记否则i会被认为是H-prime;
如何判定一个数 i 是否是H-prime,若a[i]==0,则说明其是H-prime;所以第三类数也要标记,标记为0,1外的数

两个循环(i,j)让两个H-number相乘得到y,如果这两个都为H-prime(a[i]==0&&a[j]==0),则y为H-semi-prime(即为合数)

上代码

#include <iostream>
#include<cstdio>
using namespace std;
int a[1000005]={0};
int prime[1000000];
int cnt=0;
void getanswer(int n)
{
    for(int i=5;i<=n;i+=4)///两个循环找出H-semi-prime(标记为1),H-others(标记为-1),不标记的为H-prime
    {
        for(int j=5;j<=n;j+=4)
        {
            int k=j*i;
            if(k>n)break;
            if(a[i]==0&&a[j]==0) ///两个数都要为H-prime才行
            a[k]=1;
            else a[k]=-1;///H-others(标记为-1)
        }
    }
    for(int i=1;i<=n;i++)///因为我们只要H-semi-prime,所以只要判断a[i]是否为1,其它数不管他
    {
        if(a[i]==1) cnt++;
        prime[i]=cnt;
    }
}
int main()
{
    getanswer(1000020);
    int n;
    while(1)
    {
        cin>>n;if(n==0) break;
        printf("%d %d\n",n,prime[n]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值