HDU 5364 Distribution money(水题)

Distribution money

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 353    Accepted Submission(s): 211


Problem Description
AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money would write down his ID on that part.
 

Input
There are multiply cases.
For each case,there is a single integer n(1<=n<=1000) in first line.
In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.
 

Output
Output ID of the man who should be punished.
If nobody should be punished,output -1.
 

Sample Input
  
  
3 1 1 2 4 2 1 4 3
 

Sample Output
  
  
1 -1
输入 n 表示有n份工资,n个数ai(0 <= ai <10000),表示ai这个人领了一份,问最后是否有人领的工资 大于 其他所有人的总和,有输出他的编号 ,否则输出-1。
直接判断记录每个人领的次数为x,判断是否有 x > (n-x)即可
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <cmath>
#include <map>
#include <queue>
#define N 10001
#define inf 0x3f3f3f3f
using namespace std;
int a[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
      for(int i=0;i<n;i++)
      {
          int x;
          scanf("%d",&x);
          a[x]++;
      }
      int ans=-1;
      for(int i=0;i<N;i++)
      {
          if(a[i]>(n-a[i]))
          {
              ans=i;
              break;
          }
      }
      printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值