Catch That Cow

Catch That Cow
Time Limit:2000MS Memory Limit:65536K
Total Submit:118 Accepted:30

Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

问题描述:Farmer John要抓获逃亡的牛,他的开始位置N和牛的位置K是在同一条线上(0 ≤ N,K ≤ 100,000),Farmer John的追赶走有两种方式:步行和转送。

  • Walking:FJ每分钟移动的距离是X-1 or X+1 。
  • Teleporting: FJ每分钟移动的距离是2X 。

假设牛没有意识到追赶,原地不动,多久FJ能追赶上它?

输入: FJ和牛各自的位置
输出:抓到牛用的最短时间

Sample Input
5 17

Sample Output
4

Hint
FJ抓到牛用的最短时间路径: 5-10-9-18-17, 用时四分钟。

代码:

#include "stdafx.h"
#include<iostream>  
#include<queue>  
using namespace std;  
#define M 100001  
#define INF 10000000  

// 定义一个结构体,pos表示位置,step表示所耗的分钟数。
struct POINT  
{  
    int pos;  
    int step;  
}now,m_next;

queue<POINT>Q;  
bool visited[M];  

int n,k;  
// 计算追赶牛用的最短时间
int bfs()  
{  
    // 栈清零
    while(!Q.empty())  
        Q.pop();  
    // FJ所在的位置
    now.pos=n;  
    now.step=0;  
    visited[now.pos]=true;  
    Q.push(now);  
    while(!Q.empty())  
    {  
        now=Q.front();  
        Q.pop();  
        m_next=now; 
        // 让程序更加有趣味一点
        cout << "正在疯狂的抓牛!!" << endl;
        for(int i=0;i<3;i++)  
        {  
            if(i==0)   
            {
                cout << "前进一步!" << endl;
                m_next.pos=now.pos+1;  
            }
            if(i==1)  
            {
                cout << "后退一步!" << endl;
                m_next.pos=now.pos-1;  
            }
            if(i==2)  
            {
                cout << "前进两倍距离!" << endl;
                m_next.pos=now.pos*2;  
            }
            m_next.step=now.step+1;  
            if(m_next.pos==k)  
                return m_next.step;  
            if(m_next.pos<0||m_next.pos>M)  
                continue;  
            if(!visited[m_next.pos])  
            {  
                visited[m_next.pos]=true;  
                Q.push(m_next);  
            }  
        }  
    }  
    return INF;  
}  

int main()  
{  
    while(cin>>n>>k)  
    {  
        memset(visited,false,sizeof(visited));  
        if(n<k)  
            cout<<bfs()<<endl;  
        if(n==k)  
            cout<<0<<endl;  
        if(n>k)  
            cout<<n-k<<endl;  
    }  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值