Description
用指向指针的指针的方法对n个整数排序并输出。要求将排序单独写成一个函数。整数和n在主函数中输入。最后在主函数中输出。
Input
n和n个整数
Output
排序后的整数
Sample Input
5
4 3 2 1 5
Sample Output
1 2 3 4 5
HINT
主函数已给定如下,提交时不需要包含下述主函数
/* C++代码 */
int main()
{
void sort(int **,int );
int i,n,data[20],**p,*pstr[20];
cin>>n;
for (i=0; i<n; i++)
pstr[i]=&data[i];
for (i=0; i<n; i++)
cin>>*pstr[i];
p=pstr;
sort(p,n);
for (i=0; i<n; i++)
cout<<*pstr[i]<<" ";
return 0;
}
#include <iostream>
using namespace std;
void sort(int **p,int x);
int main()
{
void sort(int **,int );
int i,n,data[20],**p,*pstr[20];
cin>>n;
for (i=0; i<n; i++)
pstr[i]=&data[i];
for (i=0; i<n; i++)
cin>>*pstr[i];
p=pstr;
sort(p,n);
for (i=0; i<n-1; i++)
cout<<*pstr[i]<<" ";
cout<<*pstr[i];
return 0;
}
void sort(int **p,int x)
{
int t;
int i,j;
for(i=0;i<x-1;i++)
for(j=0;j<x-1-i;j++)
if(**(p+j)>**(p+j+1))
{
t=**(p+j);
**(p+j)=**(p+j+1);
**(p+j+1)=t;
}
}