Simple prefix compression

描述

Many databases store the data in the character fields (and especially indices) using prefix compression. This technique compresses a sequence of strings A1, …, AN by the following method: if there are strings Ai = ai,1ai,2…ai,p and Ai + 1= ai+1,1ai+1,2…ai+1,q
such that for some j <= min(p, q) ai,1= ai+1,1, ai,2= ai+1,2, … ai,j= ai+1,j, then the second string is stored as [j]ai+1,j+1ai+1,j+2… ai+1,q, where [j] is a single character with code j.

If j = 0, that is, strings do not have any common prefix, then the second string is prefixed with zero byte, and so the total length actually increases.

Constraints
1 <= N <= 10000, 1 <= length(Ai) <= 255.
输入
First line of input contains integer number N, with following N lines containing strings A1 … AN
输出
Output must contain a single integer – minimal total length of compressed strings.
样例输入

3
abc
atest
atext

样例输出

11

解题思路

上面题目的意思大概是写个程序计算压缩过后的字符串的大小,压缩的方法是把与上个字符串相同的部分直接用数字来表示,比如给出的样例,其实就是把那三个字符串压缩位

abc
1test
3xt

代码实现

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int min(int a, int b)
{
    if(a <= b)
        return a;
    else
        return b;
}
int main(int argc, char const *argv[])
{
    int min_len = 0;
    int count = 0;
    int num = 0;
    int i, j = 0;
    char a[255], b[255];

    int n ;
    scanf("%d", &n);

    scanf("%s", a);

    int a_len = strlen(a);
    count += a_len;

    for (j = 0; j < n - 1; j++) {

        scanf("%s",b);
        int b_len = strlen(b);
        min_len = min(a_len, b_len);
        count += b_len;

        for (i = 0; i < min_len; i++) {
            if(a[i] != b[i])
                break;
        }

        count = count - i + 1;
        memcpy(a, b, b_len);
        a_len = b_len;
    }

    printf("%d\n",count);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值