探查油田——广度搜索

/*
1562:Oil Deposits
  总时间限制: 1000ms 内存限制: 65536kB
描述
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
输入
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

输出
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
样例输入
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
样例输出
0
1
2
2
来源
Mid-Central USA 1997
广度搜索,设置节点队列,8个方向搜索
清空队列、初始化队列
队首元素探查后出队
检查入队元素是否在地图内
一个元素入队时应作标记
 */
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define _N 100
struct Node
{
	int x,y;
	Node(){};
	Node(int x_,int y_):x(x_),y(y_){};
	bool isInMap(int m,int n)
	{
		return x < m && x >= 0 && y < n && y >= 0;
	}
}que[_N*_N];
int queHead,queTail;
char mat[_N][_N];
bool vis[_N][_N];
int m,n;
int dx[] = {-1, -1, -1,  0,  0,  1,  1,  1};
int dy[] = {-1,  0,  1, -1,  1, -1,  0,  1};
void bfs(int x, int y, int m, int n) {
    queHead = queTail = 0; // 清空队列
    // 将(x, y)加入队列
    que[queTail++] = Node(x, y);
    vis[x][y] = true;
    // 开始BFS搜索
    for (; queHead < queTail; ++queHead) {
        // 探查队首元素周围的8个位置
        for (int i = 0; i < 8; ++i) {
            // 根据偏移量计算位置
            Node nxt(que[queHead].x + dx[i], que[queHead].y + dy[i]);
            // 若该位置在地图中且为未访问过的'@',则加入队列
            if (nxt.isInMap(m, n) && !vis[nxt.x][nxt.y] &&
                mat[nxt.x][nxt.y] == '@') {
                que[queTail++] = nxt;
                vis[nxt.x][nxt.y] = true;
            }
        }
    }
}

int main()
{

	while(cin >> m >> n)
	{
		int ret = 0;
		if(m == 0)
			break;
		for(int i = 0; i < m ;++i)
			for(int j = 0; j < n; ++j)
				cin >> mat[i][j];
		memset(vis, 0, sizeof(vis)); // 初始化标记
		// 遍历整个地图
		for (int i = 0; i < m; ++i) {
			for (int j = 0; j < n; ++j) {
				// 探查到了一个油矿
				if (mat[i][j] == '@' && !vis[i][j])
				{
					bfs(i, j, m, n);
					ret++;
				}
			}
		}
		cout << ret << endl;
	}
}
/*
递归版本,对于每个@的位置进行8个方向搜索,如果发现@将其标记
继续搜索
 */
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char mat[101][101];
bool vis[101][101];
int m,n;
int dx[] = {-1, -1, -1,  0,  0,  1,  1,  1};
int dy[] = {-1,  0,  1, -1,  1, -1,  0,  1};
void bfs(int x,int y)
{
	if(x < 0 || x >= m || y < 0 || y >= n)
		return;
	vis[x][y] = true;
	for(int i = 0; i < 8; ++i)
	{
		if(!vis[x+dx[i]][y+dy[i]] && mat[x+dx[i]][y+dy[i]] == '@')
			bfs(x+dx[i],y+dy[i]);
	}
}
int main()
{

	while(cin >> m >> n)
	{
		int ret = 0;
		if(m == 0)
			break;
		for(int i = 0; i < m ;++i)
			for(int j = 0; j < n; ++j)
				cin >> mat[i][j];
		memset(vis, 0, sizeof(vis)); // 初始化标记
		// 遍历整个地图
		for (int i = 0; i < m; ++i) {
			for (int j = 0; j < n; ++j) {
				// 探查到了一个油矿
				if (mat[i][j] == '@' && !vis[i][j])
				{
					bfs(i, j);
					ret++;
				}
			}
		}
		cout << ret << endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值