Black And White (hdu 5113 dfs+剪枝)

46 篇文章 0 订阅

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1674    Accepted Submission(s): 456
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
  
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
  
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5426  5425  5424  5423  5422 



题意: N*M的格子用K种颜色图,每种颜色有ci个,并且每两个相邻的格子不能图一样的颜色,输出一种可行方案。

思路:dfs+剪枝,若某种颜色的数量大于剩下未图格子数量的一半则一定无解。

代码:

#include <iostream>
#include <functional>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 1005;
const int MAXN = 2005;
const int MAXM = 200010;

int N,M,K;
int number[30];
int a[10][10];
int flag;

bool isok(int x,int y)
{
    return x>=1&&x<=N&&y>=1&&y<=M;
}

bool check(int x,int y,int val)
{
    if (isok(x,y-1)&&a[x][y-1]==val) return false;
    if (isok(x-1,y)&&a[x-1][y]==val) return false;
    if (isok(x,y+1)&&a[x][y+1]==val) return false;
    if (isok(x+1,y)&&a[x+1][y]==val) return false;
    return true;
}

void dfs(int x,int y,int left)
{
    if (flag) return ;
    if (left==0)
    {
        flag=1;
        return ;
    }
    for (int i=1;i<=K;i++)
        if (number[i]>(left+1)/2) return ;
    if (y>M) dfs(x+1,1,left);
    else
    {
        for (int i=1;i<=K;i++)
        {
            if (!check(x,y,i)) continue;
            if (number[i]==0) continue;
            number[i]--;
            a[x][y]=i;
            dfs(x,y+1,left-1);
            if (flag) return ;
            a[x][y]=0;
            number[i]++;
        }
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
#endif
    int i,j,t,cas=0;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d%d",&N,&M,&K);
        for (i=1;i<=K;i++)
            scanf("%d",&number[i]);
        memset(a,0,sizeof(a));
        flag=0;
        dfs(1,1,N*M);
        printf("Case #%d:\n",++cas);
        if (!flag) printf("NO\n");
        else
        {
            printf("YES\n");
            for (i=1;i<=N;i++)
            {
                printf("%d",a[i][1]);
                for (j=2;j<=M;j++)
                    printf(" %d",a[i][j]);
                printf("\n");
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值