PAT 甲 1046 最短距离 Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^5
​​ ]), followed by N integer distances D1、D2、 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and D​N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^​4 ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 ^7
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题意:
一个环形高速公路上有 N 个出口,共有 M 次询问,每次询问回答其中两个出口之间的最短距离是多少
输入格式:
第一行首先包含一个整数 N,接下来包含 N 个整数 D1,D2,…,DN,其中 Di 是第 i 个出口与第 i+1 个出口之间的距离,DN 是第 N 个出口与第 1 个出口之间的距离。
第二行包含一个整数 M,表示询问次数。
接下来 M 行,每行包含两个整数,表示询问两个出口之间的最短距离。
C++:

#include<bits/stdc++.h>
using namespace std;
const int N = 1e5+10;
int s[N];
int main(){
    int n,m,sum_distance=0;
    cin>>n;
    for(int i = 1;i<=n;i++) cin>>s[i],sum_distance+=s[i];
    for(int i = 1; i<=n;i++) s[i]+=s[i-1];
    cin>>m;
    while(m--){
        int a,b;
        cin>>a>>b;
        if(a>b) swap(a,b);
        cout<<min(s[b-1]-s[a-1],sum_distance-(s[b-1]-s[a-1]))<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值