poj-2253 Frogger(最佳路径 Warshall算法)

Frogger
Time Limit:1000MS     Memory Limit:65536KB 
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2

Frog Distance = 1.414

/*
题意:求从石头0跳到石头1的各路径最长跳跃长度中的最小值。
Warshall算法,
L[i][j]记录石头i到j的距离;
con[i][j]=true表示在当前距离上限i与j连通,即L[i][j]<=k,若>k则con[i][j]=false;
用二分法取长度上限k,
每一次改变k的值,都相应调整con[i][j],
然后通过Warshall算法计算剩余图的传递闭包:
for(s=0;s<n;s++)
  for(i=0;i<n;i++)
    for(j=0;j<n;j++)
	  con[i][j] |=con[i][s]&con[s][j];
	//若原路径i->j连通,或子路径i->s和s->j连通,则i->j连通,否则i->j不连通
*/
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
int p[201][2];
double L[201][201];
bool con[201][201];
int main()
{
	int n,i,j,m=0;
	while(scanf("%d",&n)&&n)
	{
		m++;
		for(i=0;i<n;i++)
			scanf("%d%d",&p[i][0],&p[i][1]);
		memset(con,true,sizeof(con));
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				L[i][j]=sqrt(double((p[i][0]-p[j][0])*(p[i][0]-p[j][0])+(p[i][1]-p[j][1])*(p[i][1]-p[j][1])));
			double k,l=0,r=1500;
			while(r-l>=0.0001)
			{
				k=(l+r)/2;//二分法
				for(i=0;i<n;i++)
					for(j=0;j<n;j++)
						if(L[i][j]>k) con[i][j]=false;
						else con[i][j]=true;
				for(int s=0;s<n;s++)//Warshall算法
					for(i=0;i<n;i++)
						for(j=0;j<n;j++)
							con[i][j] |=con[i][s]&con[s][j];
						if(con[0][1]) r=k;
						else l=k;

			}
			printf("Scenario #%d\n",m);
			printf("Frog Distance = %.3lf\n",k);
			printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值