HDU 题目2138 How many prime numbers

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11330 Accepted Submission(s): 3921


Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.


Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.


Output
For each case, print the number of prime numbers you have found out.


Sample Input
3
2 3 4


Sample Output

2

C++中,运用sqrtq函数的时候,必须要把开方的数强制装换成浮点型,如果被开方数本来就是浮点型的就无所谓了。

#include <iostream>
#include <fstream>
#include <math.h>
using namespace std;

int is_prime(int m)
{
    if(m==0||m==1)
        return 0;
    else if(m==2)
        return 1;
    for(int i=2;i<=sqrt((double)m);i++)
    {
        if(m%i==0)
            return 0;
    }
    return 1;
}

int main (void)
{
    //ifstream cin("2138.txt");
    int n;
    int m;
    char ch;
    while(cin>>n)
    {
        int sum=0;
        for(int i=1;i<=n;i++)
        {
           // cin>>ch;
                int t;
                cin>>t;
                if(is_prime(t))
                    sum++;

        }
         cout<<sum<<endl;
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值