HDU 1045 Fire Net

23 篇文章 0 订阅
17 篇文章 0 订阅
这篇博客探讨了HDU 1045 Fire Net问题,重点在于理解在同一行或列上的大炮放置规则。内容指出,若有墙隔开,两个大炮可以共存于同一行或列,通过特定编号表示这种情况。
摘要由CSDN通过智能技术生成
Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7281 Accepted Submission(s): 4150


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.


Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.


Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.


Sample Input
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


Sample Output
5
1
5
2

4


同一行或者同一列上不能放两个大炮,如果两个在同一行或者同一列的大炮中间有一堵墙的话,这两个大炮就可以共存,用一个数将这个格子的所有格子表示出来。


#include <iostream>
#include <cstdio>
using namespace std;

char map[10][10];
int n;
int ans;

int judge(int k) //判断该点能否放置大炮
{
	int x = k / n;
	int y = k % n;
	int i;
	for(i=y; i>=0; i--)		//从该点往左找
	{
		if(map[x][i] == 'X')
		{
			break;
		}
		if(map[x][i] == '@')
		{
			return false;
		}
	}
	for(i=x; i>=0; i--)   //从该点往上找
	{
		if(map[i][y] == 'X')
		{
			break;
		}
		if(map[i][y] == '@')
		{
			return false;
		}
	}
	return true;
}

void dfs(int k, int cnt)
{
	if(k == n * n)
	{
		if(cnt > ans)
		{
			ans = cnt;
		}
		return ;
	}
	if(map[k/n][k%n] == '.' && judge(k))  //若该点能放置大炮
	{
		map[k/n][k%n] = '@';      //'@' 标记为大炮
		dfs(k+1,cnt+1);
		map[k/n][k%n] = '.';	//回溯时恢复该点状态
	}
	dfs(k+1,cnt);  //不放
}

int main()
{
   // freopen("B.txt","r",stdin);
	while(cin>>n,n)
	{
		ans = 0;
		for(int i=0; i<n; i++)
		{
			cin>>map[i];
		}
		dfs(0,0);
		cout<<ans<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值