POJ 1562 Oil Deposits

23 篇文章 0 订阅
17 篇文章 0 订阅
Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13709 Accepted: 7473
Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output

0
1
2

2


求有几个连通块,用深搜的方法,将每一个点遍历一遍,如果遇到‘@’就深搜,找到他的连通块,找到和这个点的连通块之后,把遍历到的‘@’都变为‘*’,表示这个油滴和上一个油滴是连着的,记为一个连通块。如果再遇到一个油滴,就表示这个油滴没有被之前的油滴连通到,说明这时候又多了一个连通块。这道题有坑,对我自己的坑,他不难,,,,,,第一个:我得习惯如果在输入0,0结束的时候,直接在while(scnaf("%d%d",&n,&m),(n||m)),但是在这里不行,程序会持续输出一系列的数,以后不再输入的时候直接加结束条件了,在while函数接口里边加上如果n和m都是0的话,直接break掉。做深搜的题的时候用,八皇后那种题一定要从0下标位置开始输入数组的字符,如果是别的题,例如这道题,数组的位置下标从哪里开始都行,不过,我的习惯就是从1开始 ,一点都不管从0开始。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int sum,n,m;
int k;
char map[105][105];
int dx[10]={-1,1,0,0,-1,1,-1,1};
int dy[10]={0,0,-1,1,-1,-1,1,1};
void dfs(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m) return ;
    if(map[x][y]=='@')
    {
        map[x][y]='*';
        for(int i=0;i<8;i++)
        {
            dfs(x+dx[i],y+dy[i]);
           // map[x][y]='@';
        }
    }
}


int main(void)
{
   // freopen("H.txt","r",stdin);
   // int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0||n==0) break;
        for(int i=0;i<n;i++)
        {
          //  getchar();
            for(int j=0;j<m;j++)
            {
                cin>>map[i][j];
            }
        }/*
        for(int i=0;i<n;i++)
        {
           // getchar();
            for(int j=0;j<=m;j++)
            {
                printf("%c",map[i][j]);
            }
            printf("\n");
        }*/
        sum=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(map[i][j]=='@')
                {
                    sum++;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",sum);

    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值