Oil Deposit

题目描述: The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
输入: The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
输出: For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
样例输入: 1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
样例输出: 0 1 2

2

View Code 
 /*
 这题题意很明确,但是不容易读,通俗来说就是要你找一共有几个@相连的块.
 相连的意思是指上下左右斜
 输入后把不是*的mar标记false
 然后进行广度搜索.第一次做的话肯定是有点难度,会了就很简单了
 */
 
 #include <stdio.h>
 #include <queue>
 using namespace std;
 #define N 101
 
 int po[9][2] = { { 0, 0 }, { 0, 1 }, { 0, -1 }, { 1, 0 }, { -1, 0 }, { 1, -1 },
 { 1, 1 }, { -1, -1 }, { -1, 1 } };
 //存储坐标变化的八种情况
 
 struct E {
     int a, b;
     void set(int x, int y) {
         a = x;
         b = y;
     }
 };
 //定义坐标结构体,好加入队列
 
 char s[N][N];
 bool mar[N][N];
 int a, b;
 int n, m;
 queue<E> Q;
 void BFS() {
     E tm, t;
     while (!Q.empty()) {
         tm = Q.front();
         Q.pop();
         for(int i = 1; i <= 8; i++){
             a = tm.a; b = tm.b;
             a += po[i][0];b += po[i][1];
             if(a >= 0 && a < n && b >= 0 && b <= m && !mar[a][b]){
                 mar[a][b] = true;
                 t.set(a, b);
                 Q.push(t);
             }
         }
     }
 }
 
 int main() {
     int count;
     E t;
     while (~scanf("%d%d", &n, &m) && !(!n && !m)) {
         count = 0;
         getchar();
         for (int i = 0; i < n; i++)
                 scanf("%s", s[i]);
         for (int i = 0; i < n; i++)
             for (int k = 0; k < m; k++)
                 mar[i][k] = s[i][k] != '@';
         for (int i = 0; i < n; i++)
             for (int k = 0; k < m; k++) {
                 if (!mar[i][k]) {
                     t.set(i, k);
                     Q.push(t);
                     BFS();
                     count++;
                 }
             }
             printf("%d\n",count);
     }
     return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值