POJ 3050 Hopscotch

23 篇文章 0 订阅
17 篇文章 0 订阅
Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2419 Accepted: 1728
Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.
Input

* Lines 1..5: The grid, five integers per line
Output

* Line 1: The number of distinct integers that can be constructed
Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
Sample Output

15


刚开始的时候没有考虑到剪枝的情况,剪枝的情况出现错误,走了5步形成的六个数不一定一定是个6位数,如果5行5列的数中间有0的话,就不会到达六位数,会造成死循环的。按步数改过之后AC。

#include <iostream>
#include <set>
#include <cstdio>
#include <cstring>
using namespace std;
int x[5]={-1,0,0,1};
int y[5]={0,-1,1,0};
set<int> p;
int map[10][10];
void dfs(int xx,int yy,int mm,int number,int sum)
{
   sum++;
   number=number*10+mm;
    if(sum==6)
    {
        p.insert(number);
        return ;
    }
    for(int i=0;i<=3;i++)
    {
        if(xx+x[i]>=1&&xx+x[i]<=5&&yy+y[i]>=1&&yy+y[i]<=5&&number<1000000)
        dfs(xx+x[i],yy+y[i],map[xx+x[i]][yy+y[i]],number,sum);

    }

}
int main(void)
{
    //freopen("D.txt","r",stdin);
    for(int i=1;i<=5;i++)
    {
        for(int j=1;j<=5;j++)
        {
            scanf("%d",&map[i][j]);
        }
    }
   // set<int> p;
    for(int i=1;i<=5;i++)
    {
        for(int j=1;j<=5;j++)
        {
            dfs(i,j,map[i][j],0,0);
        }
    }
    printf("%d\n",p.size());
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值