POJ 3259 Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 35456 Accepted: 12955

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

读了很久的题也没有弄懂,,,,最后是看了网上的解题报告把代码看懂了,才看懂了题意。。。。

题意是:

  先输入案例的个数,然后再输入3个数,v,e,w,表示这个图有v个点,e条边,w个时间逆行通道

  接下来e行输入具体的边,from,to,time,从from点到to点需要time时间,这里的time就是权值,

要注意的是,这里的边都是无向的,也就是有2*e条边,

接下来就输入虫洞的边了,虫洞有w条,

注意的是,这回的边都是单向的,因为时间逆行通道的入口只会在这条通道的一个端点,在另一端是无法使时间倒流的哦。


先介绍一下负权图:

(来自百度知道)

例如有3个点编号1,2,3,任意两点之间都存在一条边,那么1,2,3存在一个环。(这里环的定义是不太严谨的,有向边的话需要与圈区分好)
每条边都有一个边权。
我们令g(i,j)表示i,j之间的边的权值。
当g(1,2)+g(2,3)+g(3,1)<0时是负权环。
当g(1,2)+g(2,3)+g(3,1)>0时是正权环。

如果有负权图了,就说明能在一个点回到原点,使时间回到以前的任何一个时刻,就能看到以前的自己了!




#include <stdio.h>
#include <string.h>
#define inf 100000
int d[10005];
int n, m;
struct edge
{
    int from;//从顶点from指向顶点to的权值为cost的彼边
    int to;
    int cost;//权重
}edges[50005];

int bellman_ford(int m)
{
    int i,j,k,t;
    int ok;
    for(i=1; i<=n; i++)
        d[i] = inf;
    d[1] = 0;
    for(i=1; i<=n-1; i++)
    {
        ok = 1;
        for(j=1; j<=m; j++)
        {
            if(d[edges[j].from] > d[edges[j].to] + edges[j].cost)
            {
                d[edges[j].from] = d[edges[j].to] + edges[j].cost;
                ok = 0;
            }
        }
        if(ok)
            break;
    }
    for(j=1; j<=m; j++)
    {
        if(d[edges[j].from] > d[edges[j].to] + edges[j].cost)
            return 0;
    }
    return 1;
}

int main()
{
    int i, j, t, x;
    int a, b, c, w;
    //freopen("A.txt", "r", stdin);
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d", &n, &m, &w);
        memset(edges, 0, sizeof(edges));
        for(i=0, j=1; j<=m;j++)
        {
            scanf("%d%d%d", &a, &b, &c);
            i++;
            edges[i].from = a;
            edges[i].to = b;
            edges[i].cost = c;
            i++;
            edges[i].from = b;
            edges[i].to = a;
            edges[i].cost = c;

        }
        for(j=1; j<=w; j++)
        {
            scanf("%d%d%d", &a, &b, &c);

            i++;
            edges[i].from = a ;
            edges[i].to = b;
            edges[i].cost = -c;

        }
       // printf("%d\n",i);
        if(bellman_ford(i))
            printf("NO\n");
        else
            printf("YES\n");
    }
    //getch();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值