POJ 3267-The Cow Lexicon (动态规划)

J - The Cow Lexicon
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3..  W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2
题意:从给定字符串 browndcodw中删除给定单词,每个单词可删多次,答案为2即browndcodw-cow-brown=2。
分析:动态规划,状态f[i] 定为:从字符串str[i]往后删单词需要删几个,状态转移:若不能删则f[i]=f[i+1]+1;
若以str[i]开头的单词可以被删,则f[i]=MIN(f[i],f[k+1]+k+1-i-cur);即str中匹配长度-单词长度+str剩余部分状态,不好理解,举例:str中codw与cow匹配,f[k+1]+k+1-i-cur为f[w下一个位置的状态]+匹配长度需要删除的(codw-cow)
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAXN=650;
const int MAXM=350;
char da[MAXN][MAXM];
char str[MAXM];
int f[MAXM];
int MIN(const int a,const int b){	return a>b?b:a;}
int main()
{
	int n,l,i,j,k;
//	freopen("123.txt","r",stdin);
	while(~scanf("%d%d",&n,&l))
	{
		scanf("%s",str);
		for(i=0;i<n;i++)
			scanf("%s",da[i]);
		f[l]=0;
		for(i=l-1;i>=0;i--)
		{
			f[i]=f[i+1]+1;
			for(j=0;j<n;j++)
			if(da[j][0]==str[i]&&l-i>=strlen(da[j]))
			{
				int cur=0;
				for(k=i;k<l;k++)
					if(str[k]==da[j][cur])
					{
						cur++;
						if(cur==strlen(da[j]))
						{
							f[i]=MIN(f[i],f[k+1]+k+1-i-cur);
							break;
						}
					}
			}
		}
		printf("%d\n",f[0]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值