poj3190 (mulitset贪心)

J - Problem J
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.
题意:求最小空位数,使每头牛在指定时间独占一空位(一空位可两头牛轮换)
分析:贪心,以开始时间排序,在可衔接使用该空位的牛中寻找一个浪费时间最小的牛,需要用set,mutliset
代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<set>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=50005;
struct node
{
	int x,y,id;
	node(int xx=0,int yy=0,int i=0)
	{
		x=xx,y=yy;id=i;
	}
	bool operator <(node a)const
	{
		return x<a.x;
	}
};
multiset<node>mut;
node p;
int num[MAXN];
int main()
{
	int n,m,i,j;
	while(~scanf("%d",&n))
	{
		memset(num,-1,sizeof num);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&p.x,&p.y);
			p.id=i;
			mut.insert(p);
		}
		
		i=1;multiset<node>::iterator cur;
		while(!mut.empty())
		{
			
			cur=mut.upper_bound(node(mut.begin()->y));
			while(cur!=mut.end())
			{
				int tmp=cur->y;
				num[cur->id]=i;
				mut.erase(cur);
				cur=mut.upper_bound(node(tmp));
			}
			num[mut.begin()->id]=i++;
			mut.erase(mut.begin());
		}
		printf("%d\n",i-1);
		for(i=0;i<n;i++)
			printf("%d\n",num[i]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值