poj 1129 Channel Allocation

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

平面内最多26个点,给出一些点与点之间的是否相连,问最少使用多少颜色才能给这些点染色,并保证相邻点之间不同色。根据图的四色定理,最多四种颜色就能满足题意。


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
bool map[30][30];
int mark[30],n;
int ans;
bool judge(int x,int color)  //判断color颜色是否在相邻顶点中用过
{
    for (int i=0; i<n; i++)
    {
        if(i!=x && mark[i]==color && map[x][i])
        {
            return false;
        }
    }
    return true;
}
void dfs(int pos)
{
    if(pos==n)
    {
        ans=min(ans,*max_element(mark, mark+n));
        return;
    }
 
    for (int j=1; j<=4; j++)   //枚举四种颜色
    {
        if(judge(pos,j))
        {
            mark[pos]=j;
            dfs(pos+1);
        }
    }
}
int main()
{
    char str[30];
    while (scanf("%d",&n) && n)
    {
        memset(mark, 0, sizeof(mark));
        memset(map, false, sizeof(map));
        ans=30
        ;
        for (int i=0; i<n; i++)
        {
            scanf("%s",str);
            for (int j=2; j<strlen(str); j++)
            {
                map[i][str[j]-'A']=true;
                map[str[j]-'A'][i]=true;
            }
        }
        dfs(0);
        if(ans==1)
        {
            printf("1 channel needed.\n");
        }
        else
        {
            printf("%d channels needed.\n",ans);
        }
    }
    return 0;
}



邻接表+回溯

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>
using namespace std;
struct node
{
    int v,next;
}e[30*30];
int head[30],n,ans,cnt,color[30];
bool judge(int u)
{
    for (int i=head[u]; i!=-1; i=e[i].next)
    {
        if(color[u]==color[e[i].v])
        {
            return false;
        }
    }
    return true;
}
void dfs(int pos,int num_col)
{
    if(pos==n)
    {
        ans=min(ans,num_col-1);
        return;
    }
    
    for (int j=1; j<num_col; j++)
    {
        color[pos]=j;
        if(judge(pos))
        {
            dfs(pos+1, num_col);
        }
    }
    color[pos]=num_col;
    dfs(pos+1, num_col+1);
    color[pos]=0;
    
}
int main()
{
    char str[30];
    while (scanf("%d",&n) && n)
    {
        ans=30;
        cnt=0;
        memset(color, 0, sizeof(color));
        memset(head, -1, sizeof(head));
        for (int i=0; i<n; i++)
        {
            scanf("%s",str);
            for (int j=2; j<strlen(str); j++)
            {
                e[cnt].v=str[j]-'A';
                e[cnt].next=head[i];
                head[i]=cnt++;
                
                e[cnt].v=i;
                e[cnt].next=head[str[j]-'A'];
                head[str[j]-'A']=cnt++;
                
            }
        }
        dfs(0,1);
        if(ans==1)
        {
            printf("1 channel needed.\n");
        }
        else
        {
            printf("%d channels needed.\n",ans);
        }
    }
    return 0;
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值