pop 1270 Following Orders(拓扑排序)

Description

Order is an important concept in mathematics and in computer science. For example, Zorn's Lemma states: ``a partially ordered set in which every chain has an upper bound contains a maximal element.'' Order is also important in reasoning about the fix-point semantics of programs. 


This problem involves neither Zorn's Lemma nor fix-point semantics, but does involve order. 
Given a list of variable constraints of the form x < y, you are to write a program that prints all orderings of the variables that are consistent with the constraints. 


For example, given the constraints x < y and x < z there are two orderings of the variables x, y, and z that are consistent with these constraints: x y z and x z y. 

Input

The input consists of a sequence of constraint specifications. A specification consists of two lines: a list of variables on one line followed by a list of contraints on the next line. A constraint is given by a pair of variables, where x y indicates that x < y. 


All variables are single character, lower-case letters. There will be at least two variables, and no more than 20 variables in a specification. There will be at least one constraint, and no more than 50 constraints in a specification. There will be at least one, and no more than 300 orderings consistent with the contraints in a specification. 


Input is terminated by end-of-file. 

Output

For each constraint specification, all orderings consistent with the constraints should be printed. Orderings are printed in lexicographical (alphabetical) order, one per line. 


Output for different constraint specifications is separated by a blank line. 

Sample Input

a b f g
a b b f
v w x y z
v y x v z v w v

Sample Output

abfg
abgf
agbf
gabf

wxzvy
wzxvy
xwzvy
xzwvy
zwxvy
zxwvy
题意:给出很多字母,再告诉各字母间的大小关系,求出所有满足条件的字幕序列,按照字典顺序输出。字母数<=20,条件数<=50.

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char num[35],temp[35];
int indegree[35],len;
bool vis[35];
bool map[35][35];
void toposort(int cnt)
{
    if(cnt==len)
    {
        temp[cnt]='\0';
        printf("%s\n",temp);
        return;
    }
    for (int i=0; i<len; i++)
    {
        if(indegree[num[i]-'a']==0 && !vis[i])
        {
            temp[cnt]=num[i];
            vis[i]=true;
            for (int j=0; j<len; j++)
            {
                if(map[num[i]-'a'][num[j]-'a'])
                {
                    indegree[num[j]-'a']--;
                }
            }
            toposort(cnt+1);
            vis[i]=false;
            for (int j=0; j<len; j++)
            {
                if(map[num[i]-'a'][num[j]-'a'])
                {
                    indegree[num[j]-'a']++;
                }
            }
            
        }
    }
    
}
int main()
{
    while (gets(temp))
    {
        int i=0,j=0;
        memset(indegree, 0, sizeof(indegree));
        memset(map, false, sizeof(map));
        while (temp[i]!='\0')   //去掉空格
        {
            if(temp[i]==' ')
            {
                i++;
            }
            else
            {
                num[j++]=temp[i++];
            }
        }
        len=j;
        sort(num, num+len);
        gets(temp);
        i=j=0;
        while (temp[i]!='\0')  //去掉空格
        {
            if(temp[i]==' ')
            {
                i++;
            }
            else
            {
                temp[j++]=temp[i++];
            }
        }
        temp[j++]='\0';
        j=0;
        
        while (temp[j]!='\0')
        {
            
            ++j;
            indegree[temp[j]-'a']++;
            map[temp[j-1]-'a'][temp[j]-'a']=1;
            j++;
        }
        toposort(0);
        printf("\n");
        
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值