Hduoj2052【水题】

/*Picture
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16505    Accepted Submission(s): 8541


Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line. 
 

Sample Input
3 2
 

Sample Output
+---+
|   |
|   |
+---+
 

Author
xhd
 

Source
校庆杯Warm Up 
*/
#include<stdio.h>
int main() 
{
	int i, j, m, n;
	while(scanf("%d%d", &n, &m) != EOF)
	{
		m += 2;
		n += 2;
		for(i = 0; i < m; i++) //line
		{
			for(j = 0; j < n; j++)//upr
			{
				if(i == 0 || i == m-1)
				{
					if(j == 0 || j == n-1)
					printf("+");
					else
					printf("-");
				}
				else
				{
					if(j == 0 || j == n-1)
					printf("|");
					else
					printf(" ");
				}
			}
			printf("\n");
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值