Hduoj2137【水题】

/*circumgyrate the string 
Time Limit : 10000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
  Give you a string, just circumgyrate. The number N means you just   circumgyrate the string N times, and each time you circumgyrate the 
  string for 45 degree anticlockwise.

Input
  In each case there is string and a integer N. And the length of the string is always odd, so the center of the string will not be changed, 
  and the string is always horizontal at the beginning. The length of the string will not exceed 80, so we can see the complete result on the 
  screen.

Output
  For each case, print the circumgrated string.

Sample Input
asdfass 7

Sample Output
a
 s
  d
   f
    a
     s
      s

Author
wangye 
Source
HDU 2007-11 Programming Contest_WarmUp 
*/
#include<stdio.h>
#include<string.h>
int main()
{
	char s[84];
	int i, j, k, n, l;
	while(scanf("%s %d", s, &n) != EOF)
	{
		n %= 8;
		if(n < 0)
		{
			n += 8;
		}
		l = strlen(s);
		if(n == 1)
		{
			for(i = 0; i < l; ++i)
			{
				for(j = 0; j < l-1-i; ++j)
				printf(" ");
				printf("%c\n", s[l-1-i]);
			}
		}
		else if(n == 2)
		{
			for(i = 0; i < l; ++i)
			{
				for(j = 0; j < l/2; ++ j)
				printf(" ");
				printf("%c\n",s[l-1-i]);
			}
		}
		else if(n == 3)
		{
			for(i = 0; i < l; ++i)
			{
				for(j = 0; j < i; ++j)
				printf(" ");
				printf("%c\n", s[l-1-i]);
			}
		}
		else if(n == 4)
		{
			for(i = 0; i < l; ++i)
			printf("%c", s[l-1-i]);
			printf("\n");
		}
		else if(n == 5)
		{
			for(i = 0; i < l; ++i)
			{
				for(j = 0; j < l-1-i; ++j)
				printf(" ");
				printf("%c\n", s[i]);
			}
		}
		else if(n == 6)
		{
			for(i = 0; i < l; ++i)
			{
				for(j = 0; j < l/2; ++j)
				printf(" ");
				printf("%c\n",s[i]);
			}
		}
		else if(n == 7)
		{
			for(i = 0; i < l; ++i)
			{
				for(j = 0; j < i; ++j)
				printf(" ");
				printf("%c\n", s[i]);
			}
		}
		else
		{
			printf("%s\n",s);
		}
	}
	return 0;
}


题意:给定一个字符串,长度为奇数,并给出一个n,以字符串中心为旋转原点旋转,每次旋转45°,输出n次旋转后的字符串。

注意:

1.N可以是负数
2.当横向输出时,不用输出上下的N个空格和换行,当竖直输出的时候,应该输出N行左边的空格
3.所有输出字符的后面没有空格

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值