Oil Deposits
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 13004 Accepted Submission(s): 7536
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
Sample Output
0 1 2 2
Source
#include<stdio.h>
#include<string.h>
int mark[10010],f[10010];
char s[110][110];
int find(int x)
{
if(x != mark[x])
{
mark[x] = find(mark[x]);
}
return mark[x];
}
void merge(int x, int y)
{
x = find(x);
y = find(y);
if(x != y)
{
mark[x] = y;
}
}
int main()
{
int n, m, i, j;
while(scanf("%d%d", &n, &m) != EOF && n)
{
getchar();
for(i = 1; i <= n; i++)
{
for(j = 1; j <= m; j++)
scanf("%c", &s[i][j]);
getchar();
}
for( i = 1; i <= m*n; i++)
mark[i] = i;
for(i = 1; i <= n; i++)
{
for(j = 1; j <= m;j++)
{
if(s[i][j] == '*')
mark[(i-1)*m+j] = 0;
else
{
if(i-1 >= 1)//up
{
if(j-1 >= 1)//left
{
if(s[i-1][j-1] == '@')
merge((i-1)*m + j, (i-2)*m + j-1);
}
if(s[i-1][j] == '@')//up
merge((i-1)*m+j, (i-2)*m + j);
if(j+1 <= m)
{
if(s[i-1][j+1] == '@')//right
merge((i-1)*m+j, (i-2)*m + j+1);
}
}
if(j-1 >= 1)//left
{
if(s[i][j-1] == '@')
merge((i-1)*m+j, (i-1)*m+j-1);
}
}
}
}
int sum = 0;
for(i = 1; i <= m*n; i++)
if(mark[i] == i)
sum++;
printf("%d\n", sum);
}
return 0;
}
题意:给出一个矩阵,只含有字符* @ 当@和@相邻的时候,属于一个块,求输入的矩阵中块的个数。
思路 :根据题意可以用并查集,合并一个一个@最后查询有几个块。搜索暂时不会