/*A Bug's Life
Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9249 Accepted Submission(s): 2980
Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and
that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to
identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if
it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs
(at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines,
each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1,
followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs'
sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!
Scenario #2:
No suspicious bugs found!
HintHuge input,scanf is recommended.
Source
TUD Programming Contest 2005, Darmstadt, Germany
Recommend
linle | We have carefully selected several similar problems for you: 1272 1558 1811 1856 1325
*/
#include<stdio.h>
int mark[2020], a[2020];
int find(int x)
{
if(x != mark[x])
{
mark[x] = find(mark[x]);
}
return mark[x];
}
void merge(int x, int y)
{
x = find(x);
y = find(y);
if(x != y)
{
mark[x] = y;
}
}
int main()
{
int i, j, k, m, n, T, x, y, ok, cas = 1;
scanf("%d", &T);
while(T--)
{
scanf("%d%d", &n, &m);
ok = 0;
for(i = 0; i <= n+1; i++)
{
mark[i] = i;
a[i] = -1;
}
for(i = 0; i < m; i++)
{
scanf("%d%d", &x, &y);
if(ok)
continue;
if(a[x] != -1)//x有对象
{
if(a[y] != -1)// y有对象
{
if(find(x) == find(y))//若x和y在一个性别集合里
ok = 1; //同性。。
merge(x,a[y]);//否则令彼此的对象都归为和彼此一样的性别集合内
merge(y,a[x]);
}
else//y没对象
{
a[y] = x;//设定y的对象
merge(y,a[x]);//令y和x的对象在一个性别集合里
}
}
else//x没对象
{
if(a[y] != -1)//y有对象
{
a[x] = y;//设定x的对象
merge(x, a[y]);//令x和y的对象在一个性别集合里
}
else
{
a[x] = y;//彼此设定对象
a[y] = x;
}
}
}
if(ok)
printf("Scenario #%d:\nSuspicious bugs found!\n", cas++);
else
printf("Scenario #%d:\nNo suspicious bugs found!\n", cas++);
printf("\n");
}
return 0;
}
题意:给出n个虫子,编号为1~n,再给出m对关系,即x和y交配,从这m对关系中问是否有同性恋存在。。
思路:这道题一看就是并查集,但问题是怎么判断是否同性的问题,这里就分了两个集合,一旦有交配,那么假设双方肯定是异性,分别存在一个集合,即每一对关系,都可以将一个编号放入一个集合,那么怎么判断同性呢,就是当出现一对关系的时候,两个编号已经都在同一个集合里 了,所以。。。