Hduoj1020【水题】

/*Encoding
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30734    Accepted Submission(s): 13609


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each 
string consists of only 'A' - 'Z' and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

Author
ZHANG Zheng

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1019 1021 1062 1032 1039 
*/ 
#include<stdio.h>
#include<string.h>
char s1[10010];
int main()
{
	int n, i, j, k;
	scanf("%d", &n);
	getchar();
	while(n--)
	{
		gets(s1);//输入字符串 
		int l = strlen(s1);
		j = 1;
		k = 0;
		for(i = 1; i <= l; ++i)
		{
			if(s1[i] != s1[i-1])
			{
				if(j != 1)//1不用输出 
				printf("%d", j);
				printf("%c", s1[i-1]);
				j = 1;//初始化 
			}
			else
			j++;
		}
		printf("\n");
	}
	return 0;
}


题意:给出一个字符串,将连续的相同的字符简化为“KX”,k为字符的个数,X为该字符。注意这个连续,并且输出的时候是不用按字典序排序的。不要多次一举。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值