Hduoj2830 【矩阵数学】

/*Matrix Swapping II
Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1433    Accepted Submission(s): 953


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, 
and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). 
Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output
Output one line for each test case, indicating the maximum possible goodness.

Sample Input
3 4
1011
1001
0001
3 4
1010
1001
0001
 

Sample Output
4
2

Note: Huge Input, scanf() is recommended.

Source
2009 Multi-University Training Contest 2 - Host by TJU 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  2870 2845 1505 1058 1506 
*/ 
/*
#include<stdio.h>
#include<string.h>
char s[1001][1001];
int main()
{
	int i, j, k, n, m, cnt[1001];
	while(scanf("%d%d", &n, &m) != EOF)
	{
		getchar();
		memset(cnt, 0, sizeof(cnt));
		for(i = 0; i < n; ++i)
		gets(s[i]);
		for(i = 1; i <= n; ++i)//cnt
		{
			for(j = 0; j <= n-i; ++j)//limit
			{
				int num = 0;
				for(k = 0; k < m; ++k)//count
				{
					int l;
					for( l = j; l < j+i; ++l)
					{
						if(s[l][k] != '1')
						break;
					}
					if(l == j+i)
					num++;
				}
				if(num*i > cnt[i])
				cnt[i] = num*i;
			}
		}
		int max = 0;
		for(i = 1; i <= n; ++i)
		if(cnt[i] > max)
		max = cnt[i];
		printf("%d\n", max); 
	}
	return 0;
}
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int cmp(const void * x, const void * y)
{
	return *(int *)y - *(int *)x;
}
int main()
{
	int i, j, k, n, m, cnt[1001], num[1001];
	while(scanf("%d%d", &n, &m) != EOF)
	{
		int ans = 0;
		memset(num, 0, sizeof(num));
		for(i = 0; i < n; ++i)
		{
			getchar();
			for(j = 0; j < m; ++j)
			{
				char ch;
				scanf("%c", &ch);
				if(ch == '1')
				num[j]++;
				else
				num[j] = 0;
				cnt[j] = num[j];//reserve current height
			}
			qsort(cnt, m, sizeof(cnt[0]), cmp);
			for(j = 0; j < m && cnt[j] ; ++j)
			if(cnt[j]*(j+1) > ans)
			ans = cnt[j] * (j+1);
		}
		printf("%d\n",ans);
	}
	return 0;
} 


题意:给出一个矩阵,由0和1组成,现在要求可以将任意列互相交换,求仅由1组成的最大矩阵。

思路:最基本的思路就是暴力,考虑最大矩阵高为1行到n行的所有情况,统计列全为1的个数,最终统计为当最大矩阵高为i时的最大值。但是这个方法有四个for循环,所以妥妥的超时了。那么这里有一个好点的办法就是考虑以第i行为尾行的最大矩阵,求出以第i行为尾行的每一列的高度,此高度必须有第i行在内,若第i行当前列为0,则该列的值即为0,就是统计第i行为尾行每一列的高度,再将高度进行排序,那么必然可以求出以当前行为尾行的最大值。行数遍历完,再求出每一行为尾行中矩阵的最大值。

难点:就在于思路,思路越优,时间越短。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值