1061. Dating (20)

102 篇文章 0 订阅
26 篇文章 0 订阅

1061. Dating (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm
Sample Output:
THU 14:04
弄了好几个小时,结果一个测试点一直过不了,原来是SUN写错了!!!!!!自己还对着好几遍,还是舍友帮看出来的!!

  
  
时间结果得分题目语言用时(ms)内存(kB)用户
7月17日 20:00答案正确201061C++ (g++ 4.7.2)1364datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确124010/10
1答案正确13642/2
2答案正确12362/2
3答案正确13642/2
4答案正确13642/2
5答案正确12562/2
#include<iostream>
#include<string> 
using namespace std;
int main()
{
  string ss[4],sa;
  string Day[7]={"MON","TUE","WED","THU","FRI","SAT","SUN"};
  char c;
  int inc,sign;
  cin>>ss[0]>>ss[1]>>ss[2]>>ss[3];
  inc=0;
  sign=0;
    while(sign<2&&ss[0][inc]&&ss[1][inc])
  { 
  if(ss[0][inc]==ss[1][inc])
  {
    if(0==sign&&ss[1][inc]>='A'&&ss[1][inc]<='G')
    {  
      sa=sa+Day[ss[1][inc]-'A']+" ";  
      sign=1;
    }
    else  if(1==sign&&(
                    (ss[0][inc]<='N'&&ss[0][inc]>='A')||(ss[0][inc]<='9'&&ss[0][inc]>='0')
                   )
       )
    { 
       sign=2; 
      if(ss[0][inc]<='9')
      {    
        sa+="0"; 
        sa+=ss[0][inc];  
      } 
      else if(ss[0][inc]<='J')
      {  
        sa+="1";
        c=ss[0][inc]-'A'+'0'; 
        sa+=c;   
    
      } else 
      {
         sa+="2";
         c=ss[1][inc]-'K'+'0';
         sa+=c;   
      } 
      
    }
      
  }
  inc++;
  } 
  sa=sa+":";
  inc=0;
  sign=0;
    while(ss[2][inc]&&ss[3][inc]&&0==sign)
  {
        if(ss[2][inc]==ss[3][inc]&&
      (
       (ss[2][inc]>='A'&& ss[2][inc]<='Z')||
       (ss[2][inc]>='a'&&ss[2][inc]<='z'))
      )
    {
        sign=1; 
    }
       inc++;
  }  
  inc=inc--;
    c=inc/10+'0'; 
  sa+=c; 
    c=inc%10+'0';
  sa+=c; 
   cout<<sa;
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值