1008. Elevator (20)

1008. Elevator (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41
这题不用想太多,就是让你从0层爬到几层就爬到几层,向上爬一层用6秒,到目标层休息5秒,下一层4秒;问按要求总的要用多少时间。

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月23日 22:04答案正确201008C++ (g++ 4.7.2)1384datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确12521/1
1答案正确12522/2
2答案正确13482/2
3答案正确13842/2
4答案正确13842/2
5答案正确13842/2
6答案正确11802/2
7答案正确11802/2
8答案正确13002/2
9答案正确11803/3
#include<iostream> 
using namespace std; 
int main()
{
  int N, index,order,elevator;
  int up = 6, down = 4,total=5;
  cin >> N;
  total *= N;
  elevator = 0;
  for (index = 0; index < N; index++)
  {
    cin >> order; 
    total = order > elevator ? total + (order - elevator)*up : total + (elevator - order)*down;
    elevator = order; 
  }
  cout << total << endl;
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值