1012. The Best Rank (25)

102 篇文章 0 订阅
26 篇文章 0 订阅

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A
第一次提交错了几个,原来是 A > C > M > E.弄成了 A > E> M > C.;ST用来存放学生ID,各科成绩和平均分(我这里平均分就直接/4了),因为成绩这里没有小数点,所以我就开了二维数组Score[4][ ScoreNum=102],其中i=0,1,2,3对应A > C > M > E,分别先统计当前某个分数Score[i][这个分数]有多少个。
COuntScore(int(*Score)[ScoreNum], int index)
再从101到0,分别统计从Score[i][100]>=100的几个,Score[i][99]>=99的几个……Score[i][0]>=0的几个;那么,假如一个学生的课程C分数为60,那么,他对应课程C的排名为Score[1][60+1]+1;

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月25日 10:12答案正确251012C++ (g++ 4.7.2)61436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130815/15
1答案正确13082/2
2答案正确13082/2
3答案正确33083/3
4答案正确614363/3
#include<iostream>  
#include<string>
using namespace std;  
#define DigitsN 7
#define ScoreNum 102
struct STUdent
{
  char ID[DigitsN];
  int Courses[4];
};
void COuntScore(int(*Score)[ScoreNum], int index)
{ 
  for (index = ScoreNum-2; index >= 0; index--)
  {
    Score[0][index] = Score[0][index + 1] + Score[0][index];
    Score[1][index] = Score[1][index + 1] + Score[1][index];
    Score[2][index] = Score[2][index + 1] + Score[2][index];
    Score[3][index] = Score[3][index + 1] + Score[3][index];
  } 
}
int main()
{ 
  char courses[4] = {'A','C','M','E'};
  int index, i, N, M,temp,t1,t2; 
  int besTtag;
  int Score[4][ScoreNum] = { 0 };
  string id;
  STUdent *ST;
  bool Flag;
  cin >> N >> M;
  ST = new STUdent[N];
  for (index = 0; index < N; index++)
  {
    cin >> ST[index].ID >> ST[index].Courses[1] >> ST[index].Courses[2] >> ST[index].Courses[3];
    ST[index].Courses[0] = (ST[index].Courses[1] + ST[index].Courses[2] + ST[index].Courses[3]) / 4;
    Score[0][ST[index].Courses[0]]++;
    Score[1][ST[index].Courses[1]]++;
    Score[2][ST[index].Courses[2]]++;
    Score[3][ST[index].Courses[3]]++;
  }
  COuntScore(Score,index);
  for (index = 0; index < M; index++)
  {
    cin >> id;
    Flag = true;
    for (i = 0; i < N&&Flag; i++)
    {
      if (id == ST[i].ID)
      { 
        Flag = false; 
        temp = i;
      }
    }
    if (!Flag)
    {
      besTtag = 0;
      t1 = Score[besTtag][ST[temp].Courses[besTtag] + 1] + 1;
      for (i = 1; i<4; i++)
      {
        t2 =Score[i] [ST[temp].Courses[i] + 1] + 1;
        if (t1 > t2)
        {
          t1 = t2;
          besTtag = i;
        }
      }
      cout << t1 << " " << courses[besTtag] << endl;
    }
    else
      cout << "N/A" << endl;
  }
  system("pause");
  delete[] ST;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值