1031. Hello World for U (20)

102 篇文章 0 订阅
26 篇文章 0 订阅

1031. Hello World for U (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2  characters, and finally bottom-up along the vertical line with n 3  characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1  = n 3  = max { k| k <= n 2  for all 3 <= n 2  <= N } with n 1  + n 2  + n 3  - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor
对于一个字符串,把它尽量的弄成正方形的u;题目中的n1和n3为左右数量包括最后一行的头尾,n2为最后一行的数量。所以n1+n2+n3=N-2;
代码中的left_1=n1-1=(len-1)/3这里减一是为了不数最后一行的头;wordspacing=n2-2一行空格数;
#include<string> 字符串处理 用到substr(起始位置的标号,要输出的个数);
比如 HelloWorld="12345";HelloWorld.substr(1, 3)那么输出从HelloWorld[1]开始向后输出3个为234;
N>=5
1.
12345

1 5
234
2.
123456
1  6
2345
3.
1234567
1 7
2 6
345 

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月02日 09:17答案正确201031C++ (g++ 4.7.2)1308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确12568/8
1答案正确13082/2
2答案正确11802/2
3答案正确13082/2
4答案正确13042/2
5答案正确13082/2
6答案正确11802/2

#include<iostream>   
#include<string>
using namespace std;  
void worldspace(int size)
{
  for (int index = 0; index < size; index++)
    cout << " ";
}
int main()
{   
  string HelloWorld;
  int left_1, len,index,wordspacing;
  cin >> HelloWorld;
  len = HelloWorld.size();
  left_1 = (len -1)/ 3;
  wordspacing = len - 2 * left_1 - 2;
  for (index = 0; index < left_1; index++)
  {
    cout << HelloWorld[index];
    worldspace(wordspacing);
    cout << HelloWorld[len - 1 - index] << endl;;
  }
  cout << HelloWorld.substr(left_1, wordspacing+2) << endl;
  system("pause");
  return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值