【PAT(甲级)】1031 Hello World for U(详细的解题思路)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h   d
e    l
l     r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h     !
e    d
l      l
lowor

解题思路:

主要还是看懂下面这一句话

 我的理解是,先看with后面的那句,n1+n2+n3-2=N;这句就是在告诉我们,n2=N+2-2n1。然后再看前面那个max的那句。那句其实就是让n1=n3取到最大值,也就是说可以理解成 n1=n3=k;但是k=n2,而n2要满足大于等于3小于等于N。因为N\geqslant5,所以n1 = n3 = k\geqslant3。

由上面的信息我们就可以得出: 

{

        n2 = N + 2 - 2n1;

       n1 = k \leqslantn2\leqslantN;

}

所以推出 :

n1 = (N+2)/3;

n2 = N+2-2n1;

n1就是U的行数,N2就是U的列数,得出行列数后,输出U就很简单啦。

代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
	string a;
	cin>>a;
	int i=0,j=a.size()-1;
	int n1,n2;
	n1 = (j+3)/3;
	n2 = j+3-2*n1;
	for(int x=0;x<n1;x++){
		if(x!=n1-1){
			cout<<a[i];
			for(int y=0;y<n2-2;y++) cout<<" ";
			cout<<a[j]<<endl;
			i++;j--;
		}
		else{
			while(i<=j){
				cout<<a[i];
				i++;
			}
		}
	}
 	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值