1043. Is It a Binary Search Tree (25)

102 篇文章 0 订阅
13 篇文章 0 订阅

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
N个结点;
接着输入按照先序左中右 输出的队;
判断一下是 左<中<=右或者左<= 中 >右  么?是的话,输出对应的后序遍历 右-左-中;(PS:这里用到了stack 堆栈、后进先出)
                                     否则 NO

 

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月08日 15:02答案正确251043C++ (g++ 4.7.2)2308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确13086/6
1答案正确13086/6
2答案正确13082/2
3答案正确11803/3
4答案正确13003/3
5答案正确23082/2
6答案正确13042/2
7答案正确11801/1

#include<iostream>
#include<stack> 
using namespace std;   
void readln(int *BSt, int N)
{
  for (int index = 0; index < N; index++)
    cin >> BSt[index];
}
bool IsBST_mirror(int midIndex, int LastIndex, bool mirror,int *BSt)
{
  int index = midIndex + 1;
  int index2;
  bool left_sign=true;
  bool right_sign= true;
  if (mirror)
  {
    while(index < LastIndex&&BSt[index]>=BSt[midIndex]) index++;
    if (midIndex + 1 < index)left_sign = IsBST_mirror(midIndex + 1, index, mirror, BSt);
    index2 = index;
    while (index2 < LastIndex&&BSt[index2]<BSt[midIndex]) index2++;
    if (index2 < LastIndex) right_sign = false;
    else if(index<index2)right_sign = IsBST_mirror(index, index2, mirror, BSt); 
  }
  else 
  {

    while (index < LastIndex&&BSt[index] < BSt[midIndex]) index++;
    if (midIndex + 1 < index)left_sign = IsBST_mirror(midIndex + 1, index, mirror, BSt);
    index2 = index;
    while (index2 < LastIndex&&BSt[index2]>=BSt[midIndex]) index2++;
    if (index2 < LastIndex) right_sign = false;
    else if (index<index2)right_sign = IsBST_mirror(index, index2, mirror, BSt);
  }
  return left_sign&&right_sign;
} 
void stac(int *BSt, int root, int lastIndexIclude, bool mirror, stack<int>*sta)
{
  int index = root+ 1;
  sta->push(BSt[root]);
  if (mirror)
  {
    while (index <= lastIndexIclude&&BSt[index] >= BSt[root]) index++;
    if (index<=lastIndexIclude)stac(BSt, index, lastIndexIclude, mirror, sta);
    else index = lastIndexIclude + 1;
    if(root+1<index)stac(BSt,root+1, index-1, mirror, sta);
  }
  else 
  {
    while (index <= lastIndexIclude&&BSt[index] <BSt[root]) index++;
    if (index <= lastIndexIclude)stac(BSt, index, lastIndexIclude, mirror, sta);
    else index = lastIndexIclude+1;
    if (root + 1<index)stac(BSt, root + 1, index - 1, mirror, sta);
  }
} 
void printbst(stack<int>*sta)
{
  cout << "YES" << endl << sta->top();
  sta->pop();
  while (!sta->empty())
    {
      cout << " " << sta->top(); sta->pop();
        }
  cout << endl;
}
int main()
{
  int N;
  stack<int>sta;
  int * BSt;
  cin >> N;
  BSt = new int[N];
  readln(BSt, N);
  if (IsBST_mirror(0, N, true, BSt))
  { 
    stac(BSt, 0, N-1, true, &sta); 
       printbst(&sta); 
  }
  else if (IsBST_mirror(0, N, false, BSt))
  {
    stac(BSt, 0, N-1, false, &sta); 
    printbst(&sta);
  }
  else cout << "NO" << endl;
  delete[]BSt;
  system("pause");
  return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值