1046. Shortest Distance (20)

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
有N条边,接着给出1-2,2-3,3-4……n-1的长度(相当于一个环的各段长度
着给出M对要求的最少长度;
比如i ii;
这里DSum[x]存放的是1~x+1的长度,DSum[N]存放整条环长度;显然i到ii只有两条长度,两条长度和为环的长度;比较这两条得到其中最短的就可以了。
其中一条 i~ii ii>i ? DSum[ii] - DSum[i] : DSum[i] - DSum[ii]; 

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月10日 09:53答案正确201046C++ (g++ 4.7.2)42692datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130814/14
1答案正确11803/3
2答案正确426923/3
#include<iostream>   
using namespace std;  
void readln(int*DSum, int N)
{
  int index;
  DSum[0] = 0;
  for (index = 1; index <= N; index++)
  {
    cin >> DSum[index];
    DSum[index] += DSum[index - 1];
  }
}
int main()
{  
  int N,M; 
  int*DSum;
  cin >> N;
  DSum = new int[N+1];
  readln(DSum, N);
  cin >> M;
  while(M--)
  {
    int i, ii,temp;
    cin >> i >> ii; 
    i--; 
    ii--;
    temp = ii>i ? DSum[ii] - DSum[i] : DSum[i] - DSum[ii];
    cout << (temp < DSum[N] - temp ? temp : DSum[N] - temp)<< endl;
  }
  delete[]DSum;
  system("pause");
  return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值