1054. The Dominant Color (20)

1054. The Dominant Color (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
像素N*M 
接着给出N*M 的颜色bit  
求占主要的颜色;
英语不是很懂,看了别人的代码,应该就是求颜色占一半以上的那种色彩。和以前的题目几乎一样,但少了判断是否有符合条件的颜色
联动以前的vote 投票 http://xujiayu317.blog.163.com/blog/static/25475209201496114347448/

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月12日 19:39答案正确201054C++ (g++ 4.7.2)95308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130012/12
1答案正确13082/2
2答案正确952842/2
3答案正确63082/2
4答案正确11802/2
#include<iostream>  
using namespace std;   
int main()
{    
  int Nx, My,index,color,dominant;  
  cin >> Nx >> My;
  Nx = Nx*My - 1;
  cin >> dominant;
  My = 0;
  while (Nx--)
  {
    cin >> color;
    if (color == dominant)
      My++;
    else if (My==0) 
       dominant = color;
    else  My--;
  }
  cout << dominant << endl;
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值