PAT 1054. The Dominant Color (20)

http://pat.zju.edu.cn/contests/pat-a-practise/1054

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
使用map的解法:
#include <iostream>
#include <cstdio>
#include <map>
using namespace std;

int main(){
	int m, n, x;
	map<int, int> M;
	scanf("%d%d", &m, &n);
	for (int i = 0; i < n; ++i){
		for (int j = 0; j < m; ++j){
			scanf("%d", &x);
			M[x]++;
		}
	}
	int max = 0, ans;
	for (map<int, int>::iterator iter = M.begin(); iter != M.end(); ++iter){
		if (iter->second > max){
			max = iter->second;
			ans = iter->first;
		}
	}
	printf("%d\n", ans);
	return 0;
}

参照编程之美“发帖水王”的解法:

#include <cstdio>
int main(){
	int m, n, x, times = 0, candidate;
	scanf("%d%d", &m, &n);
	for (int i = 0; i < n; ++i){
		for (int j = 0; j < m; ++j){
			scanf("%d", &x);
			if (times == 0){
				candidate = x;
				++times;
			}
			else{
				if (x == candidate)
					++times;
				else
					--times;
			}
		}
	}
	printf("%d\n", candidate);
	return 0;
}





使用vector的解法我还驾驭不了 求帮忙找bug→_→:

#include <cstdio>
#include <vector>
using namespace std;

int main(){
	freopen("G:\\input.in", "r", stdin);
	int m, n, x;
	bool flag = false;
	vector<int> ivec;
	scanf("%d%d", &m, &n);
	for (int i = 0; i < n; ++i){
		for (int j = 0; j < m; ++j){
			scanf("%d", &x);
			ivec.push_back(x);
		}
	}
	vector<int>::iterator iter1, iter2;
	while (!flag){
		for (iter1 = ivec.begin(); iter1 != ivec.end();){
			for (iter2 = iter1 + 1; iter2 != ivec.end();){
				if (*iter1 == *iter2){
					iter1 = ivec.erase(iter1);
					iter2 = ivec.erase(iter2-1);
					flag = true;
					break;
				}
				else{
					++iter2;
				}
			}
			if (flag){
				flag = false;
				break;
			}
		}
	}
	printf("%d\n", ivec[0]);
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值