1072. Gas Station (30)

1072. Gas Station (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution
N个城市,M个站点, K条路,天然气站点能辐射范围最远DS;
(K行)城市或站点  城市或站点  距离;
……

PS其中城市编号1~N;站点G~GM;
目标求某一站点符合要求(越前面的条件越重要) 必须:所有的城市都在等于辐射范围或以内;
                                                                         多个必须,那么附加:在这些站点中  取(每个城市到站点的最小距离)最长的那个站点;
                                                                         多个必须并最小距离相等,那么附加:在这些站点中,取到各个城市【总距离最短】的站点;
                                                                         符合必须,并最小距离相等并总距离相等,取编号小的站点;
简单的说就是,在能够提供服务的前提下(职能问题)
                            站点到城市的最小距离越大越好,(环境或危险性问题)
                                    站点到各个城市的距离总和越少越好(浪费问题)
                                            编号选择小的(答案唯一问题)

熬夜找了好久的错误,发现错误认为char c[3]可以符合,但是G10,100也是存在的

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月15日 01:51答案正确301072C++ (g++ 4.7.2)13692datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118016/16
1答案正确13082/2
2答案正确13084/4
3答案正确13084/4
4答案正确136924/4
#include<iostream> 
#include<vector>
#include<iomanip>
#include<string>
#include<queue> 
using namespace std;   
int returnIndex(string *c,int N)
{
  int num;
  if ((*c)[0] == 'G')
  {
    sscanf(&(*c)[1], "%d", &num);
    num += N;
  }
  else  sscanf(&(*c)[0], "%d",&num); 
  return num;

}
void readln(vector<vector<pair<int,int>>>*Roads, int N,int K)
{
  string p1,p2;
  int dist;
  while (K--)
  {
    cin >> p1 >> p2 >> dist; 
    (*Roads)[returnIndex(&p1, N)].push_back(make_pair(returnIndex(&p2, N), dist));
    (*Roads)[returnIndex(&p2, N)].push_back(make_pair(returnIndex(&p1, N),dist));  
  }
}
bool spfa_BFS(vector<vector<pair<int,int>>>*Roads, int nowStation, int DS, double*nowmin, double *nowave,int M,int N)
{
  vector<int>Dist(M);
  vector<bool>InSet(M,false);
  vector<bool>DistExit(M, false);
  Dist[nowStation] = 0;
  DistExit[nowStation] = true;
  InSet[nowStation] = true;
  queue<int>QD;
  QD.push(nowStation);
  int temp;
  while (!QD.empty())
  {
    temp = QD.front();
    QD.pop(); 
    InSet[temp] = false;
    for (vector<pair<int,int>>::iterator iter=(*Roads)[temp].begin(); iter!= (*Roads)[temp].end(); iter++)
    {
      if (!DistExit[iter->first] || DistExit[iter->first] && Dist[iter->first] > Dist[temp] + iter->second)
      {
        Dist[iter->first] = Dist[temp] + iter->second;
        if (!InSet[iter->first])
        {
          QD.push(iter->first);
          InSet[iter->first] = true;
        }
        DistExit[iter->first] = true; 
      }
    }
  }/*Roads相当于GMAP就是数组邻接表,这里是用BFS求所有的house到nowStaion最短的路径。
   InSet说明已经在队伍中当做与nowStaion最近的用过。DistExit标记是否可达*/
  (*nowave) = 0;
  for (temp = 1; temp <= N; temp++)
  {
    if (!DistExit[temp] || Dist[temp] > DS)return false;
    else 
    {
      if ((*nowave) == 0)
        (*nowmin) = Dist[temp];
      else if ((*nowmin) > Dist[temp])(*nowmin) = Dist[temp];
      (*nowave) += Dist[temp];
    }
  }
  return true;
}
int main()
{
  int N, M, K, DS, anStation,nowStation;
  double minnum, average,nowmin,nowave;
  bool first;
  cin >> N >> M >> K >> DS;
  vector<vector<pair<int,int>>>Roads(N+M+1);
    readln(&Roads, N, K);
  first = true;
  M = N + M + 1;  
  for (nowStation = N + 1; nowStation < M; nowStation++)
  {

    if (spfa_BFS(&Roads, nowStation, DS, &nowmin, &nowave, M, N))
    {
      if (first || !first&&minnum<nowmin ||!first&&minnum == nowmin&&average>nowave)
      {
        anStation = nowStation;
        minnum = nowmin;
          average = nowave;
          first = false;
      }
    } 
  }
  if (first)cout << "No Solution" << endl;
  else 
  {
    cout << "G" << anStation - N << endl; 
    cout << setiosflags(ios::fixed) << setprecision(1) << minnum << " "
    << setiosflags(ios::fixed) << setprecision(1) << average / N << endl;
  }
    system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
c++解决pipeline system consists of N transfer station, some of which are connected by pipelines. For each of M pipelines the numbers of stations A[i] and B[i], which are connected by this pipeline, and its profitability C[i] are known. A profitability of a pipeline is an amount of dollars, which will be daily yielded in taxes by transferring the gas through this pipeline. Each two stations are connected by not more than one pipeline. The system was built by Soviet engineers, who knew exactly, that the gas was transferred from Ukrainian gas fields to Siberia and not the reverse. That is why the pipelines are unidirectional, i.e. each pipeline allows gas transfer from the station number A[i] to the station number B[i] only. More over, if it is possible to transfer the gas from the station X to the station Y (perhaps, through some intermediate stations), then the reverse transfer from Y to X is impossible. It is known that the gas arrives to the starting station number S and should be dispatched to the buyers on the final station number F. The President ordered the Government to find a route (i.e. a linear sequence of stations which are connected by pipelines) to transfer the gas from the starting to the final station. A profitability of this route should be maximal. A profitability of a route is a total profitability of its pipelines. Unfortunately, the President did not consider that some pipelines ceased to exist long ago, and, as a result, the gas transfer between the starting and the final stations may appear to be impossible... Input The first line contains the integer numbers N (2 ≤ N ≤ 500) and M (0 ≤ M ≤ 124750). Each of the next M lines contains the integer numbers A[i], B[i] (1 ≤ A[i], B[i] ≤ N) and C[i] (1 ≤ C[i] ≤ 10000) for the corresponding pipeline. The last line contains the integer numbers S and F (1 ≤ S, F ≤ N; S ≠ F). Output If the desired route exists, you should output its profitability. Otherwise you should output "No solution".
05-28

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值