1072. Gas Station (30)【最短路dijkstra】——PAT (Advanced Level) Practise

题目信息

1072. Gas Station (30)

时间限制200 ms
内存限制65536 kB
代码长度限制16000 B

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 10^3), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 10^4), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution

解题思路

把房子和站点放在一起当做节点,其中站点放在n+1 到 n + m之中,依次对每个站点dijkstra求最短路,同时维护全局最优值即可

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;

int n, m, k, ds, a, b, d;
map<int, map<int, int> > mp;
int maxLeng = -1, sum = 0x7fffffff, resId = -1;

void dijkstra(int id)
{
    vector<int> v(n + m + 1, 0x7fffffff); //dijkstra中记录起点到各点的最短距离
    vector<bool> vis(n + m + 1, false); //是否访问
    v[id] = 0;
    int cnt = n + m; //需要访问的点个数
    while (cnt--){
        int mx = 0x7fffffff, t = 0;
        for (int i = 1; i <= n + m; ++i){
            if (!vis[i] && v[i] <= mx){
                mx = v[i];
                t = i;
            }
        }
        if (t <= n && v[t] > ds) break; //超过最大辐射范围退出,一定注意此处的t <= n
        vis[t] = true;
        for (map<int, int>::iterator it = mp[t].begin(); it != mp[t].end(); ++it){
            v[it->first] = min(v[it->first], v[t] + it->second);
        }
    }
    if (cnt < 0){ //都在辐射范围内
        int minValue = *min_element(v.begin() + 1, v.begin() + n + 1); //最小值
        if (minValue > maxLeng){ //比全局最小值小则更新
            maxLeng = minValue;
            sum = accumulate(v.begin() + 1, v.begin() + n + 1, 0);
            resId = id;
        }else if (minValue == maxLeng){
            int t = accumulate(v.begin() + 1, v.begin() + n + 1, 0);
            if (t < sum){ //最小值与全局相同时若和更小则更新
                resId = id;
                sum = t;
            }
        }
    }
}

int main()
{
    scanf("%d%d%d%d", &n, &m, &k, &ds);
    char s1[15], s2[15];
    for (int i = 0; i < k; ++i){
        scanf("%s%s%d", s1, s2, &d);
        sscanf((s1[0] == 'G') ? s1+1:s1, "%d", &a);
        sscanf((s2[0] == 'G') ? s2+1:s2, "%d", &b);
        a += (s1[0] == 'G') ? n : 0;
        b += (s2[0] == 'G') ? n : 0;
        mp[a][b] = mp[b][a] = d;
    }
    for (int i = 1; i <= m; ++i){
        dijkstra(n + i);
    }
    if (resId == -1){
        printf("No Solution\n");
    }else{
        printf("G%d\n%0.1f %0.1f\n", resId - n, 1.0 * maxLeng, 1.0 * sum / n);
    }
    return 0;
}

个人游戏推广:
《10云方》与方块来次消除大战!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值