1094. The Largest Generation (25)

102 篇文章 0 订阅
37 篇文章 0 订阅

1094. The Largest Generation (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
输入:
N(这个家族的总成员数) M(有几个人有子嗣)
M行(父节点编号)  father  count(几个子结点)   child1  child2……childcount(对应子结点编号)
……
求哪一辈份的人数最多,是哪一代。
这里默认祖宗为编号1,祖宗为第一代;这里用BFS层遍历数个数;找出人数最多的那一代。
我一开始开动态数组的时候开太小,vs就报错。

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月19日 10:25答案正确251094C++ (g++ 4.7.2)1304datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130411/11
1答案正确12522/2
2答案正确12526/6
3答案正确13046/6
#include<iostream> 
#include<vector>
#include<queue>
using namespace std; 
void readln(vector<vector<int>>*families, int M)
{
  int father;
  int child;
  int count;
  while (M--)
  {
    cin >> father >> count;
    while (count--)
    {
      cin >> child;
      (*families)[father].push_back(child);
    }
  }
}
void BFSLevelMaxNum(vector<vector<int>>*families, int root, int &max, int&level)
{
  int size, generation=level;
  queue<int>Q;
  Q.push(root);
  while (!Q.empty())
  {
    size = Q.size();
    
    if (size > max)
    {
      max = size;
      level = generation;
    }
    while(size--)
    {
      root = Q.front();
      Q.pop();
      for (vector<int>::iterator iter = (*families)[root].begin(); iter != (*families)[root].end(); iter++) 
        Q.push((*iter));   
    }
    generation++;
  }
}
int main()
{  
  int N, M,root,max,level;
  cin >> N >> M;
  root = 1;
  vector<vector<int>>families(N+1);
  readln(&families, M); 
  max = 1;
  level = 1;
  BFSLevelMaxNum(&families,root,max,level);
  cout << max << " " << level << endl;
  system("pause");
  return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值