poj 1200 hash

Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22903 Accepted: 6433

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

转化为进制问题

题目给出一串字符,共nc种字符,求有多少不同的长度为n的子串;

先将每种字符转化为一个数,如,hash[ a [i] ]=k ;     

再依次将n个字符组成的nc进制的数,转化为十进制的数;

如acbbcd; n=3;nc=4;     故cbb=2*4^2+1*4^1+1*4^0;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
bool hash[10000000];
int a[1000000];
int main()
{
    int n,nc,i,k,j,sum,ans;
    string s;

    scanf("%d%d",&n,&nc) ;  ///输入字符的个数与种类
    cin>>s;
    k=0;

    ans=0;
    for(i=0; i<s.size(); i++)
    {
        if(a[s[i]]==0)           /// 将字符转换为数字
            a[s[i]]=k++;
        if(k==nc)      ///  nc 个字符赋值完 break;
            break;
    }
    for(i=0; i<=s.size()-n; i++)
    {
        sum=0;
        for(j=i; j<i+n; j++)
            sum+=sum*nc+a[s[j]];    ///  转化为数  进制为nc   如2进制数  11101=2^4+2^3+2^2+1

        if(hash[sum]==false)   /// 若没有出现过,则答案加一,并且标记
        {
            ans++;
            hash[sum]=true;
        }
    }
    printf("%d\n",ans);

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值